SMTP password is not settable

Our 2021.2 TeamCity installation was working normally, but then our IT department changed the password for our SMTP login account. So, I went to change the password in the Email Notifier. The new password (14 characters) has a very different number of characters then the original, so it is easy to see it change.

I type in the new password, click on Save and it reverts to something else with a different number of characters. Naturally the Test Connection feature fails to send the test email to my address.

I type in the new password, click on the Test Connection feature before hitting Save and it fails but the length stays correctly.

I have tried to update the password both when the Notifier is enabled and when it is disabled. I have tried different passwords, with different levels of complexity. It will not save and work.


1 comment
Comment actions Permalink

The password obfuscation will always display the same number of characters, "******************", regardless of how many characters the password actually contains. That is not a good indicator of whether or not the password has been saved. What is the error when using the "Test Connection" button?

You can get a little more information in teamcity-notifications.log by enabling debug-notifications logging in Administration | Diagnostics | Debug Logging and then pressing the "Test Connection" button again. This may or may not be helpful for your case, however.

It sounds as though your password is just incorrect, could you please try to use the same password outside of TeamCity to verify it does work?


Please sign in to leave a comment.