Unable to add nuget.exe tool

Hi all,

Hope someone can help. I've been asked to add the NuGet.exe tool to our on-premise TeamCity, but when I go to Administration > Integration > Tools > Install Tool...

And select NuGet.exe, it  spends 5 minutes fetching then fails; I've also tried downloading and use the upload function to upload Nuget.Commandline.Nupkg, but that just does nothing, and gives me a 'Please wait' circle.

I've checked our firewall, I've added proxy rules to allow traffic (to the best of my knowledge) and other tools appear to fetch versions fine, it's just NuGet.exe

Am I missing something? is there a specific log i can check (all the ones i've check doesn't seem to give me any errors relating to adding a tool).

 

Any help would be great.

0
3 comments

Please check for errors in teamcity-server.log. Normally, you should see some entries such as:

INFO - rver.tools.utils.URLDownloader - Downloading https://www.nuget.org/api/v2/package/NuGet.CommandLine/6.3.1 to C:\TeamCity\temp\TeamCity13761361630361864679downloaded_NuGet.CommandLine\NuGet.CommandLine.6.3.1.nupkg...
INFO - rver.tools.utils.URLDownloader - Successfully downloaded https://www.nuget.org/api/v2/package/NuGet.CommandLine/6.3.1 to C:\TeamCity\temp\TeamCity13761361630361864679downloaded_NuGet.CommandLine\NuGet.CommandLine.6.3.1.nupkg
INFO - stalled.ServerToolRegistryImpl - Installing tool NuGet.CommandLine.6.3.1 from C:\TeamCity\temp\TeamCity13761361630361864679downloaded_NuGet.CommandLine\NuGet.CommandLine.6.3.1.nupkg to C:\ProgramData\JetBrains\TeamCity\plugins\.tools\NuGet.CommandLine.6.3.1.nupkg
INFO - ols.impl.ServerToolManagerImpl - Tool NuGet.CommandLine.6.3.1 installed.

 

0

Hi Eric,

Thanks for the info.
I retried installing the tool both using the online/fetch method then the upload method to trigger the logs, but can't see anything written on the teamcity-server.log; it's almost like it doesn't even recognize that I'm trying to install it.

0

Dropped the .nupkg into plugins\tools, and it had picked it up and installed it from there. Still not sure why standard upload hadn't worked and why it wasn't even writing logs for the attempt. I've actually had to setup a new TC server from scratch, with no internet access, and was able to upload Nuget.exe normally, via the interface without issue; going have to put the original issue down to a dodgy setup/config with the instance which I've inherited. 

0

Please sign in to leave a comment.