Java 11 upgrade

Hi,

We are getting the message that we need to update Java, but we are using the bundled JRE on Windows, not an external Java install.

java.home=E:\TeamCity\jre

According to your release notes the bundled JRE is V11, so why are we getting this message and what should we do about it?

Thanks.

6 comments
Comment actions Permalink

Hi Nick,

 

if you are using the bundled version from an old release, it is most than likely still the old one installed at that point. You can follow the instructions here: https://www.jetbrains.com/help/teamcity/how-to.html#Install+Non-Bundled+Version+of+Java

 

If you were using the automatic upgrade feature, I'm afraid that the Java installation cannot be updated alongside it. We have a feature request to implement it but it's not trivial: https://youtrack.jetbrains.com/issue/TW-50725 . Alternatives would be to upgrade through the installer or simply follow the steps in the help article above.

0
Comment actions Permalink

Hi Denis,

OK, so the auto-updater doesn't update the JRE -- got it.

Options are run the installer or configure external JRE.

Thanks,

Nick

0
Comment actions Permalink

Hi, all.

We have an on-premises TeamCity Professional 2021.2.2 (build 99660) running on Windows Server 2016.

On the same server we have Azure Devops Server 2020 which has its own java installed (Open JDK):

Executing java -version I get the following:

java version "11.0.13" 2021-10-19 LTS
Java(TM) SE Runtime Environment 18.9 (build 11.0.13+10-LTS-370)
Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.13+10-LTS-370, mixed mode)

If i'm not wrong that is Java 11 and JAVA_HOME environment variable is set pointing to the binaries.

I also moved away the <TEAMCITY_HOME>\jre folder but I still get the message about the version of Java.

I don't seem to understand the method for configuring external JRE.

Any help is much appreciated.

Thanks

Martín

0
Comment actions Permalink

Hi Martin,

 

if you moved the jre away, did you restart afterwards?

 

Running "java -version" will return the result of the java that you have available in your PATH environment variable unless you run it directly on the directory that contains the executable. In both TeamCity's UI (under Administration - Diagnostics) and catalina.out within the logs folder you should be able to find the path to the java that is being used. 

 

If any of those reported using java 11 and you still get the health report, please let us know as that shouldn't happen.

1
Comment actions Permalink

Just to close this off, having installed Java 11 we copied the files to the Teamcity JRE folder and restarted, which removed the alert.

Thanks.

0
Comment actions Permalink

Denis Lapuente, It's working now!

I did restart after the deletion of the folder.

Also, the path to java was the one installed by DevOps.

As the instructions said: I downloaded the right Java, copied it into the jre folder, restarted and the warning was gone.

Evidently I was doing something wrong.

Many thanks for your time

Martín

0

Please sign in to leave a comment.