cgroup mountpoint does not exist

Hello

 

When I run build I got this error:

cgroups: cgroup mountpoint does not exist: unknown

Process exited with code 1

Process exited with code 1 (Step: Docker)

Step Docker failed

 

What can I do with it? When I run "docker build" from user with id=1000 (build agent default), everything works fine

# cat /etc/mtab |grep cgroup
cgroup2 /sys/fs/cgroup cgroup2 rw,nosuid,nodev,noexec,relatime,nsdelegate,memory_recursiveprot 0 0

# uname -a
Linux unity 5.10.0-8-amd64 #1 SMP Debian 5.10.46-4 (2021-08-03) x86_64 GNU/Linux

 

buildAgent.properties

name=Build Agent 1

ownPort=9090

serverUrl=http\://teamcity.mydomain.ru

workDir=../work

tempDir=../temp

systemDir=../system

teamcity.docker.use.sudo=true

docker-compose.yml

version: '3.1'

services:

teamcity:

image: jetbrains/teamcity-server:2021.1.2

ports:

- "8111:8111"

volumes:

- /home/teamcity/teamcity/data:/data/teamcity_server/datadir

- /home/teamcity/teamcity/log:/opt/teamcity/logs

teamcity-agent-1:

image: jetbrains/teamcity-agent:2021.1.2-linux-sudo

privileged: true

volumes:

- ./agents/agent-1/etc:/data/teamcity_agent/conf

environment:

- DOCKER_IN_DOCKER=start

1 comment
Comment actions Permalink
$ sudo sh -c 'echo "GRUB_CMDLINE_LINUX=systemd.unified_cgroup_hierarchy=false" > /etc/default/grub.d/cgroup.cfg'
$ sudo update-grub

Did the job, but why I have to rollback to cgroup v1. I use docker version 20.10.5 and it support v2

I get this error with build-agent only, "docker build ..." works like a charm

0

Please sign in to leave a comment.