Google Compute Engine agents OS is not recognized



For some reason when I try to add a new agent image under Cloud Profiles, the OS is not recognized by Teamcity and none of the build configurations are compatible with this image... It just worked a few weeks ago.

* I tried with a new image as well with an old one (that worked before)
* I don't see anything suspicious in the logs.

I wonder how TeamCity detects the image OS? Does it use the GCE metadata or something else?

Thank you in advance!

TC Enterprise 2019.2.3 (build 72031) with Google Cloud Agents 0.7.5.

Comment actions Permalink

The agent uses the java.lang.System.getProperty() method to detect the operating system name and version while the agent is starting. What operating system are you using and what version of Java is your build agent running on?

Comment actions Permalink

Ahhh, thanks a lot. Now it makes sense. I set the limit to 0 initially, thinking that 0 means "unlimited" :) Now that I set the limit to something greater than zero it just worked - a new agent came up and TeamCity recognized it as a Linux machine.

Thank you!



Please sign in to leave a comment.