Schedule Trigger not firing

Answered

Here's my trigger config:

 

And here's my VCS branch config:

Parameter of 'env.BUILD_BRANCH' is 'dev'.

My server is running with docker, and image is 'jetbrains/teamcity-server:2020.1.5'

My docker version is '19.03.13 build 4484c46d9d'

12 comments
Comment actions Permalink

It looks like your branch definitions may be incomplete in your VCS Root settings. You'll need to use the complete path for your branch in these fields, depending on which type of VCS you're using. For example, a Git repository would need to use "refs/heads/dev". The Branch Specification field in your VCS Root will set up the Logical Branch Name that you're referencing in the trigger settings. 

It may be helpful to review the documentation here: https://www.jetbrains.com/help/teamcity/working-with-feature-branches.html

 

0
Comment actions Permalink

I have updated my settings, but it still can't work.

 

Here's my settings:

 

VCS:

Default branch: refs/heads/%env.BUILD_BRANCH%

Branch specification: +refs/heads/dev

 

Schedule Trigger:

Edit Branch Filter: +refs/heads/dev

 

Parameters:

env.BUILD_BRANCH: dev

0
Comment actions Permalink

Do you have more than one VCS Root on this build configuration?

0
Comment actions Permalink

No, I have only one

0
Comment actions Permalink

Using the same VCS Root and trigger settings, it seems to work reliably for me. Are you able to run the build manually by clicking on the Run button?

0
Comment actions Permalink

Are you able to run the build manually by clicking on the Run button?

=====

Yes, it works fine. VCS trigger and Schedule trigger(manually) are both work for me.

0
Comment actions Permalink

Would you mind sharing updated screenshots with your new settings?

0
Comment actions Permalink

It looks like you're missing the ":" in your branch spec and filter fields. Try using "+:refs/heads/dev". 

1
Comment actions Permalink

Oh, thanks, I saw it. After I fix the branch filter, it works.

But... it can't work if I add trigger rule.

VCS trigger and Schedule trigger(manually) are both work where this trigger rule.

0
Comment actions Permalink

I added more than one rule like '+:dir/**'

0
Comment actions Permalink

Eric Borchardt Thanks, now the trigger is working fine!

0

Please sign in to leave a comment.