The new Jira Cloud Publisher not sending build status

I have been trying to set-up the Jira build status cloud integration. I am trying to let it send to the https://*.jira.com API. When starting a build it doesn't attempt to send anything to JIRA. I looked at logs and tried setting debugging for logs. But when I GREP logs for JIRA I can't find any besides that it my oauth credentials are saved.

  • I tried checking the OAuth permissions if they are correct.
  • I created new credentials and tried again.
  • I looked at a bunch of tabs trying to find out if I am missing some configuration that doesn't trigger a status change.
  • I have set-up another build-feature that sends info to bitbucket, that one is working just fine.
  • Looked through the documentation and issue trackets
  • I mention the jira key in a branch: feature/KEY-123 and also tried mentioning the jira key in a commit message (like described in documentation)

I am kind of lost, I really want to have this feature implemented because it is a great addition.

Here is a screenshot of my OAuth credentials:

A screenshot of my cloud integration at build features:

 

Interesting note:
I noticed that there is an attempt to send the status to JIRA for my nightly builds on master only. That one gives me a 401 error:


WARN - a.cloud.JiraCloudEventListener - Jira Cloud publisher (https://xxx.jira.com) has failed to send status of build number: 637. HTTP response content: {"error":"access_denied","error_description":"Unauthorized"}, response code: 401. at jetbrains.buildServer.publisher.jira.cloud.JiraCloudEventListener.getAccessToken(JiraCloudEventListener.java:161)

For my own triggered builds I don't see any authentication attempts.

Please sign in to leave a comment.