Issue with build triggering

Answered

I have several builds defined in my project, and only one of them is causing some issues with triggering.

What happens is that sometimes it just doesn't trigger and nothing happens. I just created a pull request, and nothing happens in team city side. 

On the other hand, sometimes it does work, and the last triggered build happened 3 days ago, so its not like the vcs root is not attached and it never works.

 

I have a build trigger: "Triggers one build per each VCS check-in (include several check-ins in build if they are from the same committer)"

 

I wonder how can i debug and find what the issue is?

Any help would be appreciated. thanks!

 

3 comments
Comment actions Permalink

Hello Tamir,

First of all, could you please share:
1) screenshot of your VCS trigger settings?
2) screenshot of your VCS Root branch specification (and default branch)?
3) if you have any custom VCS checkout rules, please share them too.

If you could provide an example of VCS commit which did not trigger a build but is available in the Pending Changes tab on the build configuration overview, that would be great.

0
Comment actions Permalink

 

 

 

 

thats the issue, i dont have anything in the pending. and i have a pull request opened in that vsc repository, but nothing happens in teamcity (no builds since 29.6 for some reason)

0
Comment actions Permalink

Hello Tamir,

OK - what is the branch specification on the VCS root in question? Does it cover the pull request references now? Do you see the PR in question in the list of available branches on the branch dropdown at the build configuration home?

0

Please sign in to leave a comment.