TeamCity Git Fetch fails after updating AWS EC2 Instance

Completed

After SSH into the AWS EC-2 instance for TeamCity Host, I ran a: sudo yum update command which updated the instance. I believe it updated Java (which I know very little about). After updating I tried to run a build on a project, I received the following error (sanatized slightly):

Failed to collect changes, error: Error collecting changes for VCS 'git fetch' command failed (repository dir: <TeamCity data dir>/system/caches/git/git-2C3466E7.git). exception: Cannot run program "/usr/lib/jvm/java-1.8.0-openjdk-1.8.0.191.b12-0.42.amzn1.x86_64/jre/bin/java" (in directory "/root/.BuildServer/system/caches/git/git-2C3466E7.git

Does anyone have any idea how to fix this?

Thank You in advance for any assistance you can provide

1 comment
Comment actions Permalink

I figured this issue out. For anyone who has the same problem, you can rollback by doing the following:

1. yum history - to see the packages

2. yum history undo id# - take the id number from above cmd to get the id

This will roll it back as it was before

 

Hope this helps

0

Please sign in to leave a comment.