URL Build trigger for file type not executing

Completed

I have setup a url build trigger to monitor a shared folder for files with a specific extension. However, whenever a new file is placed in the shared folder, the build is not triggered and there is no errors in the logs. 

I have tried the file trigger with the following formats as the folder name has a space in it.

file://"\\sharename\folder name\*.txt"

file://\\sharename\folder name\*.txt

 

3 comments
Comment actions Permalink

Hello Pranoy,

Does either of the below file URI schema work for you?
file://share/path/*.txt (.NET-style)
file:////share/path/*.txt (Java-style)

Unfortunately, URL Build trigger is not supplied as a bundled plugin for the TeamCity distribution, so the above is more a theorycraft; however, for UNC path you have, above specifications seem to apply. (please see more on https://en.wikipedia.org/wiki/File_URI_scheme#How_many_slashes? for better details on file:// protocol usage conventions).

0
Comment actions Permalink

Hi Fedore,

 

Yes I have tried a few combinations of slashes but does not seem to work.

0
Comment actions Permalink

Hello Pranoy,

I`ve just checked the sources on this plugin; unfortunately, looks like the wildcard characters are not supported for the file:// protocol. To be more precise, this plugin uses Java built-in URI resolve methods:

    try {
      return new File(url.toURI());
    } catch(URISyntaxException e) {
      return new File(url.getPath());
    }

http://svn.jetbrains.org/teamcity/plugins/url-build-trigger/trunk/url-build-trigger-server/src/jetbrains/buildServer/buildTriggers/url/FileResourceHashProvider.java

0

Please sign in to leave a comment.