teamcity agent cannot connect to gitlb

I have one TC server pod and one TC build agent pod running in k8.
Another TC build agent is running in separate server(connected with TC server).

Is with the build agent outside k8.

Failed to perform checkout on agent: '/usr/bin/git -c core.askpass=/root/temp/buildTmp/pass1564344 -c credential.helper= fetch --progress origin +refs/heads/master:refs/heads/master' command failed.
exit code: 128
stderr: fatal: unable to access 'http://gitlabrepo/': Failed to connect to gitlab-ip port 80: Connection timed out

What I tried:

  • I tried connecting VCS in VCS root with TEST CONNECTION its connecting.
  • My other agent inside k8 along with TC server is building fine.
1 comment
Comment actions Permalink

Hi and sorry for the delay. Is the problem still ongoing? The issue seems to be that the agent network config is not properly set up, connecting from the VCS Root settings could work because the server manages that connection, it is not performed through the agent.


Please sign in to leave a comment.