Disable Automatic Updates

Completed

Hi, 

I am running TeamCity Enterprise 2019.2 (build 71499) and would like to turn off the automatic updates so we can control when we update the TeamCity server.

I have set the internal property teamcity.updateCheck.interval.seconds to be 94608000 and restarted the server. It looks like it has had some sort of effect as the server is no longer checking every 2 hours for an update, however it still seems to check after about a day or so. Is there any way of disabling it totally?

Thanks

3 comments
Comment actions Permalink

Hi,

you can disable auto-updates completely using the following internal property

teamcity.server.autoUpdate.enabled = false
0
Comment actions Permalink

Hi,

Does setting that property require the server to be restarted?

Thanks

0
Comment actions Permalink

Hi,

no, you don't need to restart the server

0

Please sign in to leave a comment.