Symbol Server support fails to process PDB file

[Pdb file] java.io.IOException: Failed to update symbols file C:\BuildAgent2\work\745cebcca92a1d36\src\<path to PDB file>: error 0xb opening C:\BuildAgent2\work\745cebcca92a1d36\src\<path to PDB file>

 

I've traced this all the way down to this line of code: 

https://github.com/JetBrains/teamcity-symbol-server/blob/master/teamcity-symbol-agent/src/main/java/jetbrains/buildServer/symbols/PdbFilePatcher.java#L65

 

Which is essentially running the following command:

"C:\Program Files (x86)\Windows Kits\10\Debuggers\x64\srcsrv\pdbstr.exe" -w -p:<PDB file> -i:<input file> -s:srcsrv

 

Which if I execute manually via CMD I get the same issue

The library being build is a netstandard1.3 dll, using the 2.2 SDK

 

3
4 comments

Same issue here. Already have this issue from 2018. 

Never found a soluton

0

Hi guys,

 

usually this error message comes from the "Portable PDB" format, which is not supported, it was reported as an issue here: https://youtrack.jetbrains.com/issue/TW-58963 and it was closed as being a duplicate of the request to support the format: https://youtrack.jetbrains.com/issue/TW-41826

 

Although the dev was optimistic in bringing the support for it, I'm afraid this was never finalized, so please, watch and vote the issues. Feel free to leave any comment about those as well.

 

If you are not using the portable format but still facing the exact same issue, please share the details with us so that we can continue the investigation.

0

Thanks for the reply. 

I have chosen "Full" in Visual Studio Options for output debugging format. Should I use someting else? 

 

Kr,

0

Hello, I'm not sure if this is still active. I ran into the same issues above using a .NET Core application that built the nuget packages natively.

I enabled the Advanced Build settings that Potty Benoit suggested and also enabled,  Debug > Enabled native code debugging.

However I only managed to actually have success when i changed the build configuration to Debug from Release. Only after this adjustment did i actually manage to get the error to go away.

I hope this helps!

1

Please sign in to leave a comment.