Perforce Repository URL with ssl

Hello, I am new to Teamcity. I am having trouble to specify the Perforce Repository URL with SSL when creating a project. 

My P4PORT is "ssl:mydomain.com:1666". What is the correct perforce repo URL format with SSL?  Thanks!

1. When I specified the URL as "perforce:ssl:mydomain.com:1666", the port number was dropped with error message:

p4 error: "Perforce client error: Connect to server failed; check $P4PORT. Servname not supported for ai_socktype" - while running "p4 -u p4-user -p ssl:mydomain.com info"

 

2. When I specified the URL as "perforce://mydomain.com:1666", the error message complained about SSL was not added

p4 error: "Perforce client error: Failed client connect, server using SSL. Client must add SSL protocol prefix to P4PORT." - while running "p4 -u p4-user -p mydomain.com:1666 info"

5
5 comments

Hi,

 

as far as we can tell, the url should be "ssl:mydomain.com:1666", without the "perforce:" part. Could you try that?

0

If you are using SSL in perforce Teamcity is not working right now ....



3

Hi,

Please try manually selecting 'Perforce Helix Core' from the Type of VCS dropdown and then using the ssl:host.name:port format in the Port field. Don't forget to fill the value in the Stream field as well. You can find more info about each setting field in this article.

Thank you,

Guilherme

0

Hey all,

I am seeing the same issue as Tomasz Witkowski above.

The P4 server is cloud hosted and must be connected via SSL. When creating a project from URL, TeamCity expects the perforce:// protocol prefix. Putting these both together returns this error message, despite the fact that the port is specified in the URL.

Before this TeamCity was reporting an SSL error here, and I needed to login to the TeamCity Server host (CentOS 7) and run a p4 trust on the P4 server. I am able to p4 login to the P4 Server from the host OS.

Guilherme Barbosa Your tip above is for adding a new VCS after a project has already been created. On a fresh install of TeamCity when trying to replicate builds present in an existing project (under .teamcity at the project root) that option is not available in the administrator settings.

Any advice would be appreciated. 

5

Did anyone manage to find a solution for this? I'm having the same issue as described by Tom O'Neil.

0

Please sign in to leave a comment.