Authentication Method Private Key Disabled

I am running with Windows 10, TeamCity 2018.2, and am having problems getting a VCS root to use SSH Key Authentication for a VCS root.

We are using BitBucket to store our source code.

On my Windows 10 machine, I created an SSH Key.

I logged onto TeamCity, under the root, and uploaded the SSH Key.

When creating a new VCS Root, under Authentication Method, the only options I can select are anonymous and password.  The Private Key option is disabled.

 

What am I doing wrong?

1 comment

Hi,

 

please make sure that you are using an ssh url. TeamCity detects HTTP/S urls and disables unusable authentications, such as SSH keys.

0

Please sign in to leave a comment.