IDEA 2019.1 EAP team city plugin fails to run changes on team city

I am testing gradle integration in IDEA 2019.1 EAP IC-191.5701.16 and I am seeing problems running changes on team city prior to commit. When attempting to run a change on Team City I get the following error.

         Failed to collect VCS paths: Cannot determine repository URL for ...

If I open the same project in the same subversion workspace with IDEA 2018.3.4 and try to run the same change on team city it works fine. I made a post on the IDEA EAP community but they suggested this is the correct forum for this type of problem.

In IDEA 2018.3 I could not find version information on the IDEA Team city plugin, but in IDEA 2019.1 EAP the plugin version is v2018.2.60977.

Note the project is an import of a gradle project into IDEA. The project was created in IDEA 2019.1 EAP so I don't think the problem is with the project creation. I have seen this problem with all the gradle projects I have imported into 2019.1 EAP.

Also note the changes in the workspace can be committed to subversion.

---Update---

Upgrade to IDEA 2019.1 EAP IC-191.5849.21 and still seeing this issue. I tried looking in the IDEA logs and I don't see any errors relating to the team city remote run error. I don't think this is a team city issue as 2018.3 works with the same team city server. How do I debug this issue to find out where the problem resides? 

---Update 2---

Upgrade to IDEA 2019.1 EAP Beta IC-191.6014.8 and this problem still persists. Really stuck here and not able to run TC jobs from IDEA 2019.

---Update 3---

Upgraded to IDEA 2019.1 EAP Beta IC-191.6183-b39 and the problem still persists. Tried both import of the build.gradle file and generation of the IPR file using the gradle idea plugin. Is team city integration not supported for the EAP program?

4 comments

---Update 4---

Upgrade to the official 2019.1 release and now I can't run TC jobs from IDEA.  I am seeing the problem now in the 2019.1 release of IDEA and don't know how to get this to work.  Any help is appreciated.  Prior to upgrade 2018.1 running TC jobs from IDEA worked, now after upgrade it does not with no configuration change and exactly the same IDEA workspace.

0

Same issue for me. can anybody please assist?

1

It turned out the issue is caused by API changes on the IDE side, which were overlooked. Needed API has been restored in the IDE, so IDEA 2019.1.1 update should have it fixed. Sorry for the inconvenience

0

Final update.  I have been using IDEA 2019.1.1 IC-191.6707.7 pre-release and it is working as expected and I can once again run jobs on team city from idea.

1

Please sign in to leave a comment.