Build agent some plugins are missing / outdated

Our cloud-based build agents are now stating that they have missing / outdated plugins.

This is usually caused by a TeamCity update requiring a newer agent, however this time it is something else causing the issue.

What is the best way to find out which plugin is missing or outdated?

3
5 comments

Hi,

 

the usual approach here would be to boot up manually one agent, and see it upgrade, then either check there what is being updated, or recreate the image based on the new state. 

 

Alternatively, you could boot up the image regularly, pick up the plugin list from the agent and compare it with the plugin list from the server.

 

If all plugins are up to date, please collect the agent logs and send them to us for review.

1

I found the issue.

We use Packer to build the build agent AMI and it was creating the AMI before the agent was able to obtain updates from TeamCity.

Adding a 3-minute sleep on the end of our Packer script allowed the agent to be updated before creating the AMI.

2

Many thanks @Kbrooke, your post made me realise we'd be doing agent packing wrong – we never even started the agent during provisioning let alone waited for updates!

Rather than sleeping we now have: https://gist.github.com/btisdall/c99a7b9427fd7eff5c8f655759addae0

2

thank you  Kbrooke  Ben  I tried your script and it worked. But once I update the cloud agent with this newly built AMI. I still see the warning. Do we have to delete the TC logs as well or any other logs? In your script last line says have to cleanup, agents, logs etc. But doesn't have any more details. Can you please advise?

 
1

did the warning went away after a while? did you have to delete the logs?

i'll be facing the same situation as soon as we update the agents...

Thanks.

0

Please sign in to leave a comment.