Setting git config longpaths

I am having an issue with longpaths in Git longpaths:

[Updating sources] Failed to perform checkout on agent: '"C:\Program Files\Git\bin\git.exe" -c credential.helper= checkout -q -f 2018-3/td/npm6' command failed. exit code: 128 stderr: fatal: cannot create directory at 'Lib/External/node/node_modules/npm-registry-fetch/node_modules/make-fetch-happen/node_modules/http-proxy-agent/node_modules/agent-base/node_modules/es6-promisify/node_modules/es6-promise/lib/es6-promise/promise': Filename too long
[14:06:33][Updating sources] Error message is logged

Which can get solved by setting git property longpaths to true.

However, this has to be done before/during git clone/checkout. Is it possible to use TeamCity internal properties to set this property? Or it there another way, besides manually running 'git config --system core.longpaths true' on the build server itself?

1 comment
Comment actions Permalink

There is no such internal property. You need to properly configure Git on your agents.

0

Please sign in to leave a comment.