Installed Docker Support plugin (Linux hosted) but still no availabe docker compose agent

I have a linux hosted TeamCity instance that is running version 51047 of the Docker Support plugin. When I attempt a build, however, I see "No Available Agents" and under Connected Agents / Default Pool / Compatible Configurations I see the following "Incompatible Configurations":

Incompatible runner:

Docker Compose
Unmet requirements:
  • dockerCompose.version exists

Also under Connected Agents / Default Pool / Agent Parameters / Configuration Parameters I only see the following Docker components:

docker.server.osType  linux
docker.server.version  17.12.0
docker.version  17.12.0


Looks like this should work at the moment, what gives?


Hi Neal,

do you have docker compose available in the build agent that you want to run the build on? If you installed it recently, remember you need to restart the agent's process. If you are using a docker image as well, please check this issue with instructions on how to install docker compose on the images:


Denis - none of the build agents have docker-compose available. I've tried downloading the Docker Support plugin from the interwebs but the Teamcity UI tells me the version currently installed is newer, so I'm stuck with the current configuration.  

Also I've tried SSH'ing into the VM and making a cURL request to download docker-compose, however, even as root user, I cannot move any of the downloaded files into the /usr/local/bin folder as it's write-protected. I've also tried to remount  The weirdest thing is I'm using Teamcity's Azure template, so this is how the system is set up out of the box.


Default Agent-1
Unmet requirements:
docker.server.version exists
 I am not able to run build through an agent instead of that it goes under the build queue

Please sign in to leave a comment.