Teamcity cloud agent cannot fetch nuget dependencies and has no public IP

Answered

I'm running TeamCity 10 with a cloud agent on Amazon EC2.  

The cloud agent built off the AMI by TeamCity is unable to install nuget dependencies, it is always getting this error in the build log.

[16:13:50][restore] https://api.nuget.org/v3/index.json: Unable to load the service index for source https://api.nuget.org/v3/index.json.
[16:13:50][restore] An error occurred while sending the request.
[16:13:50][restore] Unable to connect to the remote server
[16:13:50][restore] A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 93.184.215.200:443
 
Additionally the cloud agent instance has no public ip.  Is there a setting somewhere that we can set in TC to have the agent built with a public IP?
 
However, when we manually create an instance using the same AMI, we are able to successfully build.  Everything else is the same, except for the public IP.
 
Can someone assist?

 

 
3 comments

Yeah, I have the same issue, the AWS EC2 instances created by TC cloud can't reach the nuget repository feed, so any feedback would be appreciated!

1

Hello,

Please enable auto "Enable auto assign public IP" in VPC settings. For more details, please see the comment https://teamcity-support.jetbrains.com/hc/en-us/community/posts/206835575--Agent-EC2-Agent-has-no-internet-access-VPN-#5525423.

2

Please sign in to leave a comment.