Build settings have not been finalized

Completed

None of the queued builds start on a new installation of TC 10. Agents appear and are available in TC, but the builds remain queued. The hover text of the ??? shows "Build settings have not been finalized" but I can't find anything to say what this means not how to resolve it. There are no errors in any logs on the agent or server.

4 comments

Hi Terry,

Sorry for delay. Is the issue still actual? Could you please go to Administration > Licenses page and check that the licenses are valid?

0

We did eventually figure it out through a lot of trial and error. It was down to the asset or data directory either being read only or not existing. I can't remember exactly.

All working well now though.

0

I ran into this bug and 'solved' it (at least temporarily) by enabling write permissions to the entire Agents directory.  I'm pretty sure this is a dangerous solution.

0

Hi Dylan,

 

Permissions are assigned per user. As long as the user running the agent is properly isolated and has only the necessary permissions, it should be fine. The user needs to have rw access to many of the subfolders for normal operation, though.

0

Please sign in to leave a comment.