Configuration Parameters

How do I set/change the "configuration parameters" on the agent paramaters.  I can view them all but cannot do anything with them. (all agents should be identical but some have more settings than others).

 

Thanks!

Paul.

7 comments

Hi Paul,

You can define agent parameters in <agent home>/conf/buildAgent.properties file on agent machine. For more details see the section in documentation.

0

I'd already been there, the configuration params that the agent server can see arent listed.  The section I'm talking about are shown on the screenshot

0

Do you want to add parameters? If yes, you can add them in <agent home>/conf/buildAgent.properties.

Agent automatically define the properties based on installed applications (see the section). What properties are missed on some agents? Are you sure that the appropriate applications are installed on agent machine?

0

The application is installed on all agents, the screenshot shows the issue, agent 1 has the setting, agent 2 (its not the only agent with it missing) does not.

0

Hi Paul,

Could you please enable debug logging on both agent machines and attach teamcity-agent.log file from both agents (agent1, agent2) covering the agents startup time?

0

I've emailed the logs as I cannot see how to attach them here

0

Hi Paul,

Thank you for the logs. Actually there should be no parameters with .nupkg at the end at all. It should be fixed in the newer TeamCity version. Also it's not clear why parameters are different. Do you have *.DEFAULT.nupkg on the agent the not reported it?

Could you please try to delete all NuGet versions from server and then install back needed versions? Please let me know what parameters are reported after that.

0

Please sign in to leave a comment.