Source server plugin - custom url

Hi there, I'm having a problem with the source server plugin which I'm hoping I can get some help with as I've run out of ideas!

My problem (I think) comes from Visual Studio using srcsrv.dll which does not seem to support https

We have a private teamcity instance which is accessible on the internet via https behind a proxy. To make it work well as a nuget server I have had to set it up so that it knows it is behind a proxy and its 'true' url is https.

I would still like the source server to work over http, so I can at least use it when I'm on the VPN or in the office. But the source server takes the url from the main teamcity url, and so it gives a https prefix to the url that it injects into the PDBs.

I found the github repo for the plugin, and I saw that internally it was using a shared parameter: 'symbols.sources-server-url'. So I tried to create a build step that modifies this but that didn't seem to work (I guess the parameter is read back in on the agent before the build steps run?)

So I forked the plugin code and downloaded intellij with the thought that I could change the plugin to check for an existing build parameter and use that for the url if present.

I have almost got the plugin to build - only 1 error is left:

Error:(34, 28) java: [path to build]teamcity-symbol-server\agent\src\jetbrains\buildServer\symbols\ArtifactPathHelper.java:34: shouldProcess(java.lang.String) has private access in jetbrains.buildServer.agent.impl.artifacts.ArchivePreprocessor

But I'm not a java developer. I can't see how this code could possibly work, but it does build on the jetbrains build server. I'm using the same JDK version as the build server, I downloaded the same dependency artifact (teamcity-build) that the latest build used.

 

I don't know what else to try, and now I really want to make this work! So sorry for the long message, but any help much appreciated.

 

3 comments

Thanks, I looked at the code again and found something new. For posterity, there is a setting:

symbols.server-own-url

Which does seem to allow you to override the base url that gets embedded in the pdbs.

0

Oh, year! i forgot that i've already added this toggle. it should handle your needs.

0

Please sign in to leave a comment.