Unknown data processor type 'mstest' in service message 'importData'

Answered

Hello!

We are using TeamCity 9.1.7 (build 37573) recently upgraded from 9.0 and no have this issue before.

Now we have problem:

[12:59:51][Step 2/5] Unknown data processor type 'mstest' in service message 'importData'
[12:59:51][Step 2/5] ##teamcity[importData type='mstest' path='C:\TeamCity\buildAgent\temp\buildTmp\mstest_results_1463565464803.teamcity.trx']
 
 
Could you tell what we need to check and change?
 
Best, Alex
9 comments

Hello Alex,

Could you please find the config XML file of affected build configuration in the <TeamCity Data Directory>/config/projects/<ProjectID>/buildTypes/? Please attach this config and also full build log.

0

Thank you for the logs. Unfortunately we were not able to reproduce the issue.

Could you please also attach the plugin itself.
From server:

  1. <TeamCity_installation_dir>\webapps\ROOT\WEB-INF\plugins\xml-report-plugin.zip

  2. archived <TeamCity_installation_dir>\webapps\ROOT\WEB-INF\plugins\.unpacked\xml-report-plugin directory

From agent: archived <AGENT_DIR>\plugins\xml-report-plugin directory.

Thank you!

 

0

Alina, please check:

https://drive.google.com/file/d/0B1gFe2F9vE6FMnRxZFZBeGxETzA/view?usp=sharing
https://drive.google.com/file/d/0B1gFe2F9vE6FaC1kTC1uczl1aWM/view?usp=sharing
https://drive.google.com/file/d/0B1gFe2F9vE6FZHFfVkFrTTVoeVk/view?usp=sharing

For "archived <TeamCity_installation_dir>\webapps\ROOT\WEB-INF\plugins\.unpacked\xml-report-plugin directory" i have made screenshot of folder structure because i haven't xml-report-plugin directory.

Thank you!

0

Thank you for all details and sorry that it takes so long to investigate the issue. 

Unfortunately the reason is still not clear. Could you please also attach screenshot of the Administration > Plugins List page and teamcity-server.log covering the server start time.

Thank you!

0

Hello Alex,

Thank you for the logs. According to the screenshot bundled "XML-based reports" plugin, according to the log there was "not enough space on the disk" error while upgrading and seems that server has not been upgraded successfully.

Please reinstall TeamCity (use current database and data directory). Please let me know if it helps.

0

Hello, Alina! Thank you. Reinstall helps :) I have reinstalled teamcity and unit test results have loaded correctly.

Best, Alex

0

Hi Alex,

Thank you for the update. Glad that issue was resolved!

0

Please sign in to leave a comment.