.vdproj build command fails w/ HRESULT = '8000000A' on TeamCity, succeeds via command line

Answered

I have added the suggested MS registry hack of adding in the EnableOutOfProcBuild, and it did seem to fix my issue when running from the command line - the devenv.com call to build the vdproj succeeds at the command line level.  If I run that exact same command embedded in a .proj file from a TeamCity build runner, I get the HRESULT = '8000000A' error, and I have no idea why - shouldn't the results be exactly the same?

I tried running the command via a command line runner, just the raw command, also fails.  This is the exact same command that if typed into a command line prompt works.  Why would the team city runner fail it?

4 comments

Hello Andrew,

Please use the following guidelines to investigate the issue.
If build still misbehaves in TeamCity, then please create a new issue in our tracker detailing the case. Please attach all the build step settings, the build log, all agent logs covering the build, the command you used in the console to run the build and the full console output of the build.

0

Hi Andrew,

 

Have you found a workaround on this?

 

Thanks,

0

I had the same problem with Jenkins CI Tool
The below steps will resolve the issue.

 

1.Open Service.msc as administrator
2.go to service for me Jenkins, for you May TFS
3.Right-click and select properties
4.Click on Log On tab
5.Select This account and put user and password of your user. Make sure user is available by using Browse.
6.Click Apply and Ok.
7.Restart the service.

 

0

Please sign in to leave a comment.