Build Agent accessing /usr/local/include

Answered

Hi,

When running the build locally ( make ), the build complete successfully.

When using the very same machine thru a build agent, I'm getting the following error during the build execution:

 

blabla.h:35:30: error: /usr/include/blabla/blabla.h: Permission denied

Does sandboxing my project is a prerequisite for building using a Build Agent, or would it be possible to allow the agent to access files outside the "task" ?

( I'm well aware of the repercussions; But I'm trying to move forward one step at a time )

 

Tsachi

3 comments

Hello Tsachi,

Have you tried to run the same build via command line on agent machine in working directory under the same user that the agent is running? Does it run successfully? It seems that the agent is running under a different user. Please check it. If it's not the case, then please follow the guidelines.

0

I tried to reproduce the issue from the agent build directory directly. It was failing there as well.

I eventually found the source of the issue; It was symbolic links.

Since symbolic links were not copied correctly, it just ignored them and attempted to access the user/local directory, where it failed.

There are two items on my TC wish-list :

1. make sure to copy symbolic links between the artifacts of one build and the dependent build's artifact dependency of a second build.

2. make sure to preserve the file mode across artifacts. ( in particular, execution bit ! )

0

Hello,

Thank you for the update. We have the related requests in our tracker:

1. https://youtrack.jetbrains.com/issue/TW-17903

2. https://youtrack.jetbrains.com/issue/TW-4651

Please vote for these requests.

0

Please sign in to leave a comment.