NuGet Package are not in the feed

Answered

Hi all,

We're trying to get our TC has a nuget package server. We did all the steps refered here (http://blog.jetbrains.com/teamcity/2011/12/setting-up-teamcity-as-a-native-nuget-server/) and the build generates the nuget right, and we can see/download it in the artifacts tabs. Although we make these steps and configurations has recomended  (and clearing metadata caches) the nuget never ends up on the feed :/ 

http://OUR-TC/httpAuth/app/nuget/v1/FeedService.svc/

TeamCity version is: 9.1.6

So we can't used them on VS projects...

I'm out of ideas... any suggestion?

Thanks a lot

6 comments

Hello,

Did you try to add TeamCity NuGet feed to Visual Studio as suggested in the blog post? Are you able to manage packages?
Do you see any packages if you open "http://teamcity_server_url/httpAuth/app/nuget/v1/FeedService.svc/Packages()" in browser?

0

Hi Alina, 

Thanks for your answer,  but you suggested the same instructions that we have done, the same blog post. We also tried others configurations from other users and we still can see the packages on feeds and ob VS.

 

Regards

0

What response do you get if you open "http://teamcity_server_url/httpAuth/app/nuget/v1/FeedService.svc/" and "http://teamcity_server_url/httpAuth/app/nuget/v1/FeedService.svc/Packages()" links in browser? 

Are there any related errors/warnings in the teamcity-server.log file?

0

So Alina,

when execute on browser the http://teamcity_server_url/httpAuth/app/nuget/v1/FeedService.svc/  we got:

<service xmlns="http://www.w3.org/2007/app" xmlns:atom="http://www.w3.org/2005/Atom" xmlns:app="http://www.w3.org/2007/app" xml:base="http://TC_server/httpAuth/app/nuget/v1/FeedService.svc/">
<workspace>
<atom:title>Default</atom:title>
<collection href="Packages">
<atom:title>Packages</atom:title>
</collection>
</workspace>
</service>
 
But when we execute http://teamcity_server_url/httpAuth/app/nuget/v1/FeedService.svc/Packages() we got alot more info, and some referenced packages :P nice.
 
Now I tried again to add the feed on Visual Studio, and they showed up :P hurray!
 
But why the url http://teamcity_server_url/httpAuth/app/nuget/v1/FeedService.svc don't return a feed with the packages ? this got me wondering...
 
thanks for your help
0

Ok, so I founded that the guestAuth url doesn't return any values, because the project it self don't have "guest" user premissions, so in order to have packages available on the guest Url the project has to have guest permissions also.

 

thanks

1

Glad it works! http://teamcity_server_url/httpAuth/app/nuget/v1/FeedService.svc/ is link to NuGet Feed, and /Packages() list the packages. We will update the UI. Sorry for the inconvenience.

0

Please sign in to leave a comment.