Several typical problems with TeamCity.

Hi all,

using TeamCity is great but often we encounter 2 issues we cannot solve and it is very annoying. Can anyone advice on that?

1) We want to build all new git tags created. A problem is that SOMETIMES TeamCity does not see new tags. 

For example, we create git tag, push it to repository, we see it in Stash on remote side BUT TeamCity doesn't see it. It is not available in "enhanced Run" options (Run ... on on projects list), and it is not build automatically despite we have tags tracking set and that checkbox on "use tags as branches" too.

2) We have added some branch to git repository and we want to build it. A problem is that we dont see it in a list of branches available for building in "enhanced Run" options. We cannot select it. We can build it only if we make it main branch in VCS settings, but thats wrong.

3 comments

Hi Dmitry,

How is build specification configured for the affected VCS root? What Checking for changes interval is set?
Are there any errors/warnings in teamcity-vcs.log?

0

Alina,

1) How is build specification configured for the affected VCS root?

you mean branch specification? like that:

+:refs/tags/*

+:refs/heads/<main_branch_name>

.. and default branch <main_branch_name>

2) What Checking for changes interval is set?

60 seconds.

3) How is build specification configured for the affected VCS root?

That time we didn't viewed it. Will do it after next fail and post here.

0

And even worse - when I press on project and thus open list of previous build, then select <Default branch> in the upper left corner - it selects a set of build which resulted from TWO different branches. These branches relate to the same GIT repository and their names are similair (refs/heads/version1.5 and refs/heads/version1.7), but these are different branches!

0

Please sign in to leave a comment.