Failed to start build due to largefiles extension

Hi,

Would someone please help me to resolve the following issue. Sometimes TeamCity cannot start a build due to the this error:

Failed to build patch for build ... due to error: 'hg --config ui.interactive=False --config auth.tc.prefix=* --config auth.tc.username=USER --config auth.tc.password=****** --config "auth.tc.schemes=http https" cat -o c:\Utils\TeamCity\bin\..\temp\hg1\%p -r 8f02ade705b7 MyFile.dll' command failed.
stderr: abort: No such file or directory: c:\Utils\TeamCity\bin\..\temp\hg1\.hglf/MyFile.dll

I am pretty sure about these observations:

1) Running a clean build always works. So the problem appears only if there is a non-clean build.

2) The error appears only if the last changeset contains at least one file stored with largefiles extension (we use Mercurial).

3 comments
Comment actions Permalink

Hello Maxim,

What TeamCity version do you use? Have you specified the Mercurial configto enable the largefiles extension in VCS root settings? For more detail please see https://confluence.jetbrains.com/display/TCDL/Mercurial.

If everything is configured correctly, then please attach teamcity-vcs.log file.

0
Comment actions Permalink

Thank you. Yes, as I said in general my setup works fine (I just have to do a clean build when I get a build error). So largefiles is certainly enabled. I am using the most up to date TC version 9.1.6.

I am attaching the log.

0

Please sign in to leave a comment.