Nuget server assumes (incorrectly) that my URL is HTTP

Our TeamCity is 7.1 (build 23907)  on SQL Server database w/ 2 agents running on a Windows 2008 R2 server. We are using IIS to redirect traffic from "https://ourserver.ourdomain.com" to the local internal team city address. The Server URL setting in Global Settings is correctly set to "https://ourserver.ourdomain.com". This server is actually remote from our office, so we are using HTTPS for all communications and have guest accounts turned off.

This morning I created a new project to build a git project and put the artifact in the local nuget server. I enabled the nuget server and it decided to use the URL "http://ourserver.ourdomain.com/httpAuth/app/nuget/v1/FeedService.svc" (which is obviously not accessible since we don't allow http connections to this server). I can access the raw feed using "https://ourserver.ourdomain.com/..." and can register it in visual studio as a package source, but the feed continues to report the base package URL as HTTP instead of HTTPS, so I can't actually download the packages.

Is there a configuration somewhere I can use to manually override this URL to make it HTTPS? Is there a reason this isn't either using the value from General Settings in TeamCity or reflecting the base URL value I use to request the feed?

1 comment
Comment actions Permalink

Hello,

Unfortunately, this was caused by the set of issues
- OData feed requires server to put it's full URL into the response data (don't get why?)
- TeamCity supports as many URLs as you like, i.e. http(s)://localhost http(s)://hostname http(s)://some-domain.local and so on
- We use HTTP requires to fetch original URL to be used in feed rendering
- For some reason it's handy to use reverse proxy => so requrest url may be altered in HTTP headers

What you need to do is to configure tomcat and revers proxy rightly to make it resolve original requirest url.
Please find the description in http://youtrack.jetbrains.com/issue/TW-22031  (and of course vote for it!)

The original issue is http://youtrack.jetbrains.com/issue/TW-20584,

0

Please sign in to leave a comment.