eol-style properties from subversion ignored

I have a Linux shell script with Unix-style EOL (LF) in subversion. When
this file is checked out
to a build agent on Windows (for building an install kit) the line-endings
get converted to
Windows-style (CRLF). I have tried to prevent this from happening but I've
failed.

I've tried setting subversion property eol-style to LF, but that doesn't
change anything.
Is there any way I can tell the teamserver not to convert linefeeds?


1 comment
Comment actions Permalink


It should be fixed in the next eap version (but you'll have to invoke "reset
sources" for all agents).
Thanks!

"Mikael Karlsson" <mikael.karlsson@pitch.se> wrote in message
news:e6mrhe$cdr$1@is.intellij.net...
>I have a Linux shell script with Unix-style EOL (LF) in subversion. When
>this file is checked out

to a build agent on Windows (for building an install kit) the line-endings
get converted to
Windows-style (CRLF). I have tried to prevent this from happening but I've
failed.

>

I've tried setting subversion property eol-style to LF, but that doesn't
change anything.
Is there any way I can tell the teamserver not to convert linefeeds?

>



0

Please sign in to leave a comment.