perforce plugin and P4CONFIG

I installed the eap version of IDEA in order to evaluate delayed
checkins. In configuring the Perforce plugin, I chose the default
setting which is to use P4CONFIG. However, that's not working for
me. My p4 settings are

$ p4 set
P4CLIENT=teamserver (config)
P4CONFIG=.p4 (set)
P4DEBUG=server=1 (set)
P4EDITOR=gnuclient (set)
P4JOURNAL=journal (set -s)
P4LOG=log (set -s)
P4PORT=localhost:1600 (config)
P4ROOT=C:\sw\Perforce (set -s)
P4USER=stevea (set)

and in my project root I have a .p4 file that has

$ cat .p4
P4PORT=localhost:1600
P4CLIENT=teamserver

but the plugin keeps using my machine name as a client name.

I found an old issue similar to this here:

http://www.jetbrains.net/jira/browse/IDEA-5002

but it's unresolved. Yet use of P4CONFIG is the default setting in the
new version. Will this be fixed?

If this is not the right forum to bring this up, please tell me where
to report this.

Thanks.

--
-- Steve

Please sign in to leave a comment.