Problem with auto update (CVS)

Hi,

TC work almost perfectly on my system. The problem is that it does not
update correctly from CVS. It does detect new changes and also tries to
update them. The comment from the update is even correct (from last commit),
but the files (located in buildAgent/work) are never updated. They remain
unchanged.

If I empty the buildAgent/work dir, then TC will check out all new changes
and all works well. Am I missing out on something? Maybe some config error?

I'm using CVS (pserver), TC Version 1.0-beta build 1574 (got the same
behavior on an older version).

Melv Ng



3 comments
Comment actions Permalink

Melv Ng wrote:

Hi,

TC work almost perfectly on my system. The problem is that it does not
update correctly from CVS. It does detect new changes and also tries to
update them. The comment from the update is even correct (from last commit),
but the files (located in buildAgent/work) are never updated. They remain
unchanged.

If I empty the buildAgent/work dir, then TC will check out all new changes
and all works well. Am I missing out on something? Maybe some config error?

I'm using CVS (pserver), TC Version 1.0-beta build 1574 (got the same
behavior on an older version).


I'd say that such behaviour is far from perfect. May I ask you to file a Jira
request and include logs as described at
http://www.jetbrains.net/confluence/display/TW/HowtoDebug+problems ?

Please also include information about your CVS server version.

As a workaround, you may check "Clean checkout" checkbox in your build
configuration.

Regards,

KIR

--
Kirill Maximov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Melv Ng wrote:

Hi,

TC work almost perfectly on my system. The problem is that it does not
update correctly from CVS. It does detect new changes and also tries to
update them. The comment from the update is even correct (from last commit),
but the files (located in buildAgent/work) are never updated. They remain
unchanged.

If I empty the buildAgent/work dir, then TC will check out all new changes
and all works well. Am I missing out on something? Maybe some config error?

I'm using CVS (pserver), TC Version 1.0-beta build 1574 (got the same
behavior on an older version).


Please also take a look at http://www.jetbrains.net/jira/browse/TW-592 .
Do you have the similar problem?


Melv Ng




--
Kirill Maximov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Please watch this request:
http://www.jetbrains.net/jira/browse/TW-592



--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Melv Ng" <pkng8791@hotmail.com> wrote in message
news:ed913a$si7$2@is.intellij.net...

Hi,

>

TC work almost perfectly on my system. The problem is that it does not
update correctly from CVS. It does detect new changes and also tries to
update them. The comment from the update is even correct (from last
commit),
but the files (located in buildAgent/work) are never updated. They remain
unchanged.

>

If I empty the buildAgent/work dir, then TC will check out all new changes
and all works well. Am I missing out on something? Maybe some config
error?

>

I'm using CVS (pserver), TC Version 1.0-beta build 1574 (got the same
behavior on an older version).

>

Melv Ng

>
>



0

Please sign in to leave a comment.