Email not working

Hi,

Now that my builds are generating the output expected, I am working on the details. One recent problem is that email is no longer generated at all from the Linux box that serves as both the TC server and agent. I haven't received email since 9/29 which was when I was using build 1611. Must the server or agent run as root in order to get email? Currently they are not. I see nothing in the log files about this.

-Dave

7 comments
Comment actions Permalink

Dave Leskovac wrote:

Hi,

Now that my builds are generating the output expected, I am working on the details. One recent problem is that email is no longer generated at all from the Linux box that serves as both the TC server and agent. I haven't received email since 9/29 which was when I was using build 1611. Must the server or agent run as root in order to get email? Currently they are not. I see nothing in the log files about this.


Please check the SMTP hostname in the Server settings on Administration page of the TeamCity.

Please also make sure that mail can be sent successfully from this Linux box using simple
e-mail program.

Regards,
KIR


--
Kirill Maximov
Software Developer
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0
Comment actions Permalink

Yes. I can send email from the Linux box directly using either "mail" or "sendmail". The SMTP hostname is correct.

0
Comment actions Permalink

I also am not seeing any emails (with TC build 1654)

0
Comment actions Permalink

Hi

I seem to remember a similar issue when setting up TC with an earlier eap build. It didn't appear to like the hostname in the email config xml.

As TC was running on the same box as the smtp server I just set the host to 'localhost' and this worked.

Have you tried doing this or using the ip address of the mail server?

Paul

0
Comment actions Permalink

Hi Paul,

I seem to remember a similar issue when setting up TC with an earlier eap build. It didn't appear to like the hostname in the email config xml.
As TC was running on the same box as the smtp server I just set the host to 'localhost' and this worked.
Have you tried doing this or using the ip address of the mail server?


The default value of the SMTP host in the "Email Notifier Settings" section of the admin console UI was "mail". I changed the value to the DNS name of our mail server and that didn't work. I'll try both "localhost" and the IP address of the mail server.

Thanks,
-Dave

0
Comment actions Permalink

Windows firewall was blocking my outbound emails. My mistake.

0
Comment actions Permalink

I figured out the email problem. I just had it reporting on the wrong project. Email works fine now.

-Dave

0

Please sign in to leave a comment.