Problems with inspections

I tried to use the Inspections runner using JDK 1.6 Beta2 but I always
get the following error message:

"The JDK is not configured properly for this project. Inspection cannot
proceed. 1.6 not found"

(commandline dump below)

In fact I'm not sure what I have to do. I've found a posting in this
newsgroup that I have to set a JDK_HOME variable somewhere. But where?
Is it a property for the BuildAgent or for the Build Configuration? I
tried both but none of them works.

Could someone shed some light on this?

Thanks,
Axel

P.S.: Everything is running on the same machine (my WinXP dev machine):
Teamserver #1712, BuildAgent, latest Idea 6 EAP #6068).


Commandline:

"C:\Program Files\Java\jdk1.6.0\bin\java.exe"
-Dbuild.working.dir=c:\progra1\jetbra1\teamci1\builda1\work\Agilo
-Didea.build.server.checkout.on.server=true
-DDotNetFramework1.1_Path=C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322
-Dbuild.number=11 -DDotNetFramework1.1= -Duser.language=de
-Duser.country=DE -Didea.build.server.buildType.id=bt2 -Dos.version=5.1
-Duser.timezone=Europe/Berlin -Dfile.encoding=Cp1252 -Dfile.separator=\
"-Djdk.1.6=C:\Program Files\Java\jdk1.6.0"
-DDotNetFramework2.0_Path=C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
-Dos.arch=x86 -Didea.no.jdk.check=true -DDotNetFramework2.0=
-Dbuild.vcs.number.1=5650 "-Didea.plugins.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\plugins"
-Duser.name=SYSTEM "-Dos.name=Windows XP"
-Didea.build.server.is.personal=false -Didea.build.agent.port=9090
-DDotNetFrameworkSDK1.1= "-Didea.system.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\system"
-Didea.build.server.run.type=Inspection "-Didea.config.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\config"
-Duser.variant= -Didea.build.server.execution.timeout=0
"-DDotNetFrameworkSDK1.1_Path=C:\Program Files\Microsoft.NET\SDK\v1.1"
-Didea.build.server.project.name=Agilo -Dsuccessful.build.number=1
"-Didea.home.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea"
"-Duser.home=C:\Documents and Settings\guicking"
-Didea.build.server.build.id=42 "-DJDK_HOME=C:\Program Files\jdk1.6.0"
-Dpath.separator=; -Demma.disable.source=true
"-Xbootclasspath/p:C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\boot.jar"
-classpath "C:\Program Files\Java\jdk1.6.0\lib\tools.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\idea.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\extensions.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\openapi.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\jdom.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\log4j.jar"
com.intellij.idea.Main inspect "C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\etc\Agilo.ipr"
profile C:\WINDOWS\Temp\inspection28423result -e -v3

11 comments
Comment actions Permalink

Hello Axel,

You do not need any preparations if you are running inspections with the
same JDK as your build agent. Thus you do not need to set up any properties
at all (as I can see from command line you can remove "-DJDK_HOME=C:\Program
Files\jdk1.6.0").

Though I do not understand why it doesn't work as is. What build do you use?
Could you please use the latest EAP? (I will try to reproduce the problem.)

If you have a number of JDK set up for your project then you would need to
set up thier names and paths in "Properties and environment variables": property
name should be: jdk.YOUR_JDK_NAME; value e.g. %env.JAVA_HOME%. We are working
to make it more natural. Sorry for inconvenience.

Thank you very much for your attention.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

I tried to use the Inspections runner using JDK 1.6 Beta2 but I always
get the following error message:

"The JDK is not configured properly for this project. Inspection
cannot proceed. 1.6 not found"

(commandline dump below)

In fact I'm not sure what I have to do. I've found a posting in this
newsgroup that I have to set a JDK_HOME variable somewhere. But where?
Is it a property for the BuildAgent or for the Build Configuration? I
tried both but none of them works.

Could someone shed some light on this?

Thanks,
Axel
P.S.: Everything is running on the same machine (my WinXP dev
machine): Teamserver #1712, BuildAgent, latest Idea 6 EAP #6068).

Commandline:

"C:\Program Files\Java\jdk1.6.0\bin\java.exe"
-Dbuild.working.dir=c:\progra1\jetbra1\teamci1\builda1\work\Agilo
-Didea.build.server.checkout.on.server=true
-DDotNetFramework1.1_Path=C:\WINDOWS\Microsoft.NET\Framework\v1.1.4322
-Dbuild.number=11 -DDotNetFramework1.1= -Duser.language=de
-Duser.country=DE -Didea.build.server.buildType.id=bt2
-Dos.version=5.1 -Duser.timezone=Europe/Berlin -Dfile.encoding=Cp1252
-Dfile.separator=\ "-Djdk.1.6=C:\Program Files\Java\jdk1.6.0"
-DDotNetFramework2.0_Path=C:\WINDOWS\Microsoft.NET\Framework\v2.0.5072
7 -Dos.arch=x86 -Didea.no.jdk.check=true -DDotNetFramework2.0=
-Dbuild.vcs.number.1=5650 "-Didea.plugins.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\plugins"
-Duser.name=SYSTEM "-Dos.name=Windows XP"
-Didea.build.server.is.personal=false -Didea.build.agent.port=9090
-DDotNetFrameworkSDK1.1= "-Didea.system.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\system"
-Didea.build.server.run.type=Inspection "-Didea.config.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\config"
-Duser.variant= -Didea.build.server.execution.timeout=0
"-DDotNetFrameworkSDK1.1_Path=C:\Program Files\Microsoft.NET\SDK\v1.1"
-Didea.build.server.project.name=Agilo -Dsuccessful.build.number=1
"-Didea.home.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea"
"-Duser.home=C:\Documents and Settings\guicking"
-Didea.build.server.build.id=42 "-DJDK_HOME=C:\Program Files\jdk1.6.0"
-Dpath.separator=; -Demma.disable.source=true
"-Xbootclasspath/p:C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\boot.jar"
-classpath "C:\Program Files\Java\jdk1.6.0\lib\tools.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\idea.jar;C:\
Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\extensions.j
ar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\openapi.jar;
C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\jdom.jar;C:\
Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\log4j.jar"
com.intellij.idea.Main inspect "C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\etc\Agilo.ipr"
profile C:\WINDOWS\Temp\inspection28423result -e -v3



0
Comment actions Permalink

Hello Anna,
thanks for your fast reply. I was already using the latest TeamCity
Build #1712. I tried to execute the commandline from a DOS box - same
result. I then played around a bit using different values for the system
property "jdk.1.6" (i.e. pointing to various JDK installations) as well
as setting the JAVA_HOME environment variable. Always the same results.

Thanks for your help,
Axel

0
Comment actions Permalink

Hello Axel,

if your project jdk has name 1.6 then everything is right here (I mean that
"-Djdk.1.6=..." is correct). I am going to investigate is it 1.6 related
problem ...

Could you please check your .ipr file and send me the line corresponding
to jdk?

Thank you.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Hello Anna,
thanks for your fast reply. I was already using the latest TeamCity
Build #1712. I tried to execute the commandline from a DOS box - same
result. I then played around a bit using different values for the
system
property "jdk.1.6" (i.e. pointing to various JDK installations) as
well
as setting the JAVA_HOME environment variable. Always the same
results.
Thanks for your help,
Axel



0
Comment actions Permalink

The only line in the ipr file containing the string "1.6" is the following.

]]>

Regards,
Axel


Anna Kozlova wrote:

Hello Axel,

if your project jdk has name 1.6 then everything is right here (I mean
that "-Djdk.1.6=..." is correct). I am going to investigate is it 1.6
related problem ...
Could you please check your .ipr file and send me the line corresponding
to jdk?

0
Comment actions Permalink

Hello Axel,

Thank you

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

The only line in the ipr file containing the string "1.6" is the
following.

<component name="ProjectRootManager" version="2"
assert-keyword="true" jdk-15="false" project-jdk-name="1.6"
project-jdk-type="JavaSDK">
<output url="file://$APPLICATION_HOME_DIR$/bin" />
</component>
Regards,
Axel
Anna Kozlova wrote:

>> Hello Axel,
>>
>> if your project jdk has name 1.6 then everything is right here (I
>> mean
>> that "-Djdk.1.6=..." is correct). I am going to investigate is it 1.6
>> related problem ...
>> Could you please check your .ipr file and send me the line
>> corresponding
>> to jdk?


0
Comment actions Permalink

Hello Axel,

Could you please try to run from command line:

"C:\Program Files\Java\jdk1.6.0\bin\java.exe" "-Djdk.1.6=C:\Program Files\Java\jdk1.6.0"
-Didea.no.jdk.check=true "-Didea.plugins.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\plugins"
"-Didea.system.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\system"
-Didea.build.server.run.type=Inspection "-Didea.config.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\config"
"-Didea.home.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea"
"-Xbootclasspath/p:C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\boot.jar"
-classpath "C:\Program Files\Java\jdk1.6.0\lib\tools.jar;C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\idea.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\extensions.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\openapi.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\jdom.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\log4j.jar" com.intellij.idea.Main
inspect "C:\Program Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\etc\Agilo.ipr"
profile C:\WINDOWS\Temp\inspection28423result -e -v3

I've keep only inspection specific properties from your command line.

Thank you for your patience

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

The only line in the ipr file containing the string "1.6" is the
following.

<component name="ProjectRootManager" version="2"
assert-keyword="true" jdk-15="false" project-jdk-name="1.6"
project-jdk-type="JavaSDK">
<output url="file://$APPLICATION_HOME_DIR$/bin" />
</component>
Regards,
Axel
Anna Kozlova wrote:

>> Hello Axel,
>>
>> if your project jdk has name 1.6 then everything is right here (I
>> mean
>> that "-Djdk.1.6=..." is correct). I am going to investigate is it 1.6
>> related problem ...
>> Could you please check your .ipr file and send me the line
>> corresponding
>> to jdk?


0
Comment actions Permalink

Hello Anna,
that produces the following output:

"Team server agent is only licensed to be used with TeamServer."

Does this help you?

Regards,
Axel


Anna Kozlova wrote:

Hello Axel,

Could you please try to run from command line:

"C:\Program Files\Java\jdk1.6.0\bin\java.exe" "-Djdk.1.6=C:\Program
Files\Java\jdk1.6.0" -Didea.no.jdk.check=true
"-Didea.plugins.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\plugins"
"-Didea.system.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\system"
-Didea.build.server.run.type=Inspection "-Didea.config.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\config"
"-Didea.home.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea"
"-Xbootclasspath/p:C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\boot.jar"
-classpath "C:\Program Files\Java\jdk1.6.0\lib\tools.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\idea.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\extensions.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\openapi.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\jdom.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\log4j.jar"
com.intellij.idea.Main inspect "C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\etc\Agilo.ipr"
profile C:\WINDOWS\Temp\inspection28423result -e -v3

I've keep only inspection specific properties from your command line.

0
Comment actions Permalink

Hello Axel,

No :(

Indeed I forgot to mention that TeamCity must be running when command is
executed. (There are some license checks with it). Could you please repeat?

Thank you.

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Hello Anna,
that produces the following output:
"Team server agent is only licensed to be used with TeamServer."

Does this help you?

Regards,
Axel
Anna Kozlova wrote:

>> Hello Axel,
>>
>> Could you please try to run from command line:
>>
>> "C:\Program Files\Java\jdk1.6.0\bin\java.exe" "-Djdk.1.6=C:\Program
>> Files\Java\jdk1.6.0" -Didea.no.jdk.check=true
>> "-Didea.plugins.path=C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\plugins"
>> "-Didea.system.path=C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\system"
>> -Didea.build.server.run.type=Inspection
>> "-Didea.config.path=C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\config"
>> "-Didea.home.path=C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea"
>> "-Xbootclasspath/p:C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\boot.jar"
>> -classpath "C:\Program Files\Java\jdk1.6.0\lib\tools.jar;C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\idea.jar;C:
>> \Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\extensions.
>> jar;C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\openapi.jar
>> ;C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\jdom.jar;C:
>> \Program
>> Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\log4j.jar"
>> com.intellij.idea.Main inspect "C:\Program
>> Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\etc\Agilo.ipr"
>> profile C:\WINDOWS\Temp\inspection28423result -e -v3
>>
>> I've keep only inspection specific properties from your command line.
>>


0
Comment actions Permalink

Hmm, TeamCity and agent were both running. I tested it again - same results.

Should I file a Jira issue?

Regards,
Axel


Anna Kozlova wrote:

Hello Axel,

No :(
Indeed I forgot to mention that TeamCity must be running when command is
executed. (There are some license checks with it). Could you please repeat?

Thank you.

---------------------
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

>> Hello Anna,
>> that produces the following output:
>> "Team server agent is only licensed to be used with TeamServer."
>>
>> Does this help you?
>>
>> Regards,
>> Axel

0
Comment actions Permalink

Hello Axel,

you can watch progress:

http://www.jetbrains.net/jira/browse/TW-1101

Could you please give a last try:

"C:\Program Files\Java\jdk1.6.0\bin\java.exe" "-Djdk.1.6=C:\Program Files\Java\jdk1.6.0"
-Didea.no.jdk.check=true "-Didea.plugins.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\plugins"
-Didea.build.agent.port=9090 "-Didea.system.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\system"
"-Didea.config.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\config"
"-Didea.home.path=C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea"
"-Xbootclasspath/p:C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\boot.jar"
-classpath "C:\Program Files\Java\jdk1.6.0\lib\tools.jar;C:\Program Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\idea.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\extensions.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\openapi.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\jdom.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\log4j.jar" com.intellij.idea.Main
inspect "C:\Program Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\etc\Agilo.ipr"
profile C:\WINDOWS\Temp\inspection28423result -e -v3

Thank you very much

-


Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

Hmm, TeamCity and agent were both running. I tested it again - same
results.

Should I file a Jira issue?

Regards,
Axel
Anna Kozlova wrote:

>> Hello Axel,
>>
>> No :(
>> Indeed I forgot to mention that TeamCity must be running when command
>> is
>> executed. (There are some license checks with it). Could you please
>> repeat?
>> Thank you.
>>
>> -


>> Anna Kozlova
>> JetBrains Inc.
>> http://www.intellij.com
>> "Develop with pleasure!"
>>> Hello Anna,
>>> that produces the following output:
>>> "Team server agent is only licensed to be used with TeamServer."
>>> Does this help you?
>>>
>>> Regards,
>>> Axel


0
Comment actions Permalink

No, this produces the "1.6 not found" error message again.

OK, thanks for sticking to this problem. ;)

Regards,
Axel


Anna Kozlova wrote:

Hello Axel,

you can watch progress:
http://www.jetbrains.net/jira/browse/TW-1101

Could you please give a last try:

"C:\Program Files\Java\jdk1.6.0\bin\java.exe" "-Djdk.1.6=C:\Program
Files\Java\jdk1.6.0" -Didea.no.jdk.check=true
"-Didea.plugins.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\plugins"
-Didea.build.agent.port=9090 "-Didea.system.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\system"
"-Didea.config.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\config"
"-Didea.home.path=C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea"
"-Xbootclasspath/p:C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\boot.jar"
-classpath "C:\Program Files\Java\jdk1.6.0\lib\tools.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\idea.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\extensions.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\openapi.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\jdom.jar;C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\plugins\idea\lib\log4j.jar"
com.intellij.idea.Main inspect "C:\Program
Files\JetBrains\TeamCity-1712\buildAgent\work\Agilo\etc\Agilo.ipr"
profile C:\WINDOWS\Temp\inspection28423result -e -v3

Thank you very much

---------------------
Anna Kozlova
JetBrains Inc.
http://www.intellij.com
"Develop with pleasure!"

0

Please sign in to leave a comment.