Incompatible runner

I've upgraded TC to 1.1.1, (last available GA version) then upgraded build
agents, and now I'm having some trouble

No agent is show as compatible agents for my builds. Instead, all agents
appear to be incompatible with this message: Incompatible runner: 'Ant'

I was using ant for my builds...

what can I check, and what can I do?

kind regards!
Gaston


1 comment
Comment actions Permalink

Hi Gaston,

Gaston Martin wrote:

I've upgraded TC to 1.1.1, (last available GA version) then upgraded build
agents, and now I'm having some trouble

No agent is show as compatible agents for my builds. Instead, all agents
appear to be incompatible with this message: Incompatible runner: 'Ant'


This sounds pretty strange, because agent should have auto-upgraded.
So thats either a bug, or you've interrupted build agent manually while
upgrade was in progress.

I suggest to create a Jira request and attach log from agent. To fix agent,
stop it, remove buildAgent/plugins directory, and start again.
It takes some time for agent to upgrade ( usually a couple of minutes).

Hope this helps,
KIR


I was using ant for my builds...

what can I check, and what can I do?

kind regards!
Gaston



--
Kirill Maximov
JetBrains, Inc.
http://www.jetbrains.com
"Develop with pleasure!"

0

Please sign in to leave a comment.