Teamcity continuously polling CVS server

Hello,

We have Teamcity running on one of our servers. It is continuously polling the CVS server, or at least in 3-5 second intervals. I have changed the CVS quiet period in the Teamcity administration webpage to 3600 seconds for example, but the changes have no effect. Is this the right parameter to change, if not which parameter(s) do have to be changed, otherwise why does it ignore a different setting of seconds?

Thank you

4 comments
Comment actions Permalink

I think what you want is to set:

-Dmodification.check.interval=]]>

on the command line of the tomcat instance running Team City Server. You can do this with JAVA_OPTS or just modify the startup script directly.

You can find details at:

http://www.jetbrains.net/confluence/display/TW/TeamCity+FAQ

--Tim

0
Comment actions Permalink

Thank you for the information, it worked.

0
Comment actions Permalink

I would suggest that this setting should become part of the CVS (or other VCS) root setup. Especially in larger setups, you're like to either have multiple CVS servers of different capabilities, or multiple projects with different requirements on how often they need to be build, and how up-to-date they need to be.

For instance, I have a nightly build for code-coverage reports. No need to keep polling the CVS server for that.

It should also be possible to disable polling the CVS server, in case of projects that don't trigger builds on CVS checkins such as the above nightly report.

Maarten

0
Comment actions Permalink

We plan to support per-project VCS polling interval:

http://www.jetbrains.net/jira/browse/TW-1680

Please feel free to comment/vote for it.

Kind regards,
KIR

0

Please sign in to leave a comment.