teamcity builder doesn't understand russian symbols

We comment our code in russian and build runner issues a warning for
every such comment, though the project compiles fine at programmers pc-s.

For example:

C:\builda~1\work\Server\server\server\replicationAnnotations\src\replicationAnnotations\CppMirrored.java:4:
warning: unmappable character for encoding UTF-8[javac2] * ?????????,
??????? ?????? ???? ? ?????, ??? ??????????? ?? ?????? "????????".

How this can be fixed (I suppose that I should just change some settings)?

Vitaly Berov

9 comments
Comment actions Permalink

Hello Vitaly,

Do you use TC 1.2?


--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

We comment our code in russian and build runner issues a warning for
every such comment, though the project compiles fine at programmers
pc-s.

For example:



C:\builda~1\work\Server\server\server\replicationAnnotations\src\repli
cationAnnotations\CppMirrored.java:4:

warning: unmappable character for encoding UTF-8[javac2] * ?????????,

??????? ?????? ???? ? ?????, ??? ??????????? ?? ?????? "????????".

How this can be fixed (I suppose that I should just change some
settings)?

Vitaly Berov



0
Comment actions Permalink

Eugene Petrenko wrote:

Hello Vitaly,

Do you use TC 1.2?

Yes, I've just downloaded it for evaluation. TeamCity Version 1.2 (build
1784)

Vitaly Berov

0
Comment actions Permalink

Hello Vitaly,

This problem is fixed in Agra EAP. Sorry for inconvinience.

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Eugene Petrenko wrote:

>> Hello Vitaly,
>>
>> Do you use TC 1.2?
>>

Yes, I've just downloaded it for evaluation. TeamCity Version 1.2
(build 1784)

Vitaly Berov



0
Comment actions Permalink

Eugene Petrenko wrote:

Hello Vitaly,

This problem is fixed in Agra EAP. Sorry for inconvinience.


I'm not sure our project wants to use unstable version of build system :)
Can you propose any workaround for this bug? For example, can I suppress
these warnings somehow?

What is a roadmap for Agra? When are you going to release it?
Is the current build of Agra stable (3654 released Jan 30)?
Are bugs in Agra have the same priority as bugs in current TeamCity version?

Vitaly Berov

0
Comment actions Permalink

Vitaly Berov wrote:

Eugene Petrenko wrote:

>> Hello Vitaly,
>>
>> This problem is fixed in Agra EAP. Sorry for inconvinience.
>>


I'm not sure our project wants to use unstable version of build system :)
Can you propose any workaround for this bug? For example, can I suppress
these warnings somehow?

What is a roadmap for Agra? When are you going to release it?
Is the current build of Agra stable (3654 released Jan 30)?
Are bugs in Agra have the same priority as bugs in current TeamCity
version?

Vitaly Berov


Can anybody propose a workaround? Some way to suppress warnings?

Vitaly Berov

0
Comment actions Permalink

Eugene Petrenko wrote:

Hello Vitaly,

This problem is fixed in Agra EAP. Sorry for inconvinience.


Sorry, but I cannot confirm that. IPR-builds still create the same warning in
3776. This is because it thinks that it should use UTF-8 as source-encoding: In
the generated integrationBuild.xml there's this line:

]]>

Assuming UTF-8 source files is IMHO usually not a good idea. Better leave that
up to the user and/or the platform's default setting.

Sascha

0
Comment actions Permalink

Vitaly Berov wrote:

Can anybody propose a workaround? Some way to suppress warnings?


I've found a solution for Ant-builds on Linux: You have to set the LC_CTYPE
environment variable to the language/country/encoding combination you need. This

export LC_CTYPE=ru_RU.ISO-8859-5

should work for you. Also check if maybe LANG is set to something else. If in
doubt, unset it.

BTW: This isn't a harmless warning, but will lead to broken code if there are
unmappable symbols in String literals!

HTH,
Sascha

0
Comment actions Permalink

Sascha Weinreuter wrote:

Eugene Petrenko wrote:

>> Hello Vitaly,
>>
>> This problem is fixed in Agra EAP. Sorry for inconvinience.


Sorry, but I cannot confirm that. IPR-builds still create the same warning in
3776. This is because it thinks that it should use UTF-8 as source-encoding: In
the generated integrationBuild.xml there's this line:

<property name="source.encoding" value="UTF-8" />

Assuming UTF-8 source files is IMHO usually not a good idea. Better leave that
up to the user and/or the platform's default setting.

Sascha


It seems that you've found a workaround. I should set UTF-8 as "Default
Encoding" in IDEA settings and convert all my files to UTF-8.
And, I think, it's better to have UTF-8 encoding for source files to not
have problems with portability. But, anyway, TeamCity shouldn't behave
this way :)

Thanks for help

Vitaly Berov

0
Comment actions Permalink

In fact, you can specify system property "source.encoding" and to set it to a value which corresponds to your files encoding.

Regards,
KIR

0

Please sign in to leave a comment.