How to configure Teamcity check for updates

Hi!
I want to configure teamcity build 4037 to check for vcs (cvs) updates less frequently. I added the -Dmodification.check.interval=3600 parameter via tomcat5w.exe to the tomcat java configuration properties. I restarted the server and Teamcity still polls every 5 seconds for changes on my cvs?
Did the property change?
Do I have to add/change another property?
Or is this feature broken in build 4037?

thomas

5 comments
Comment actions Permalink

I want to configure teamcity build 4037 to check for
vcs (cvs) updates less frequently. I added the
-Dmodification.check.interval=3600 parameter via
tomcat5w.exe to the tomcat java configuration
properties.


This is what worked for me:
Add this line to TeamCity/bin/catalina.sh just under the big comment at the top:
JAVA_OPTS="$ -Dmodification.check.interval=3600"

-Dave

0
Comment actions Permalink

Hi Dave!
Thanks for your reply.

We run TeamCity and the integrated tomcat server as a Windows Service on a Windows 2003 Server. You suggested to add the java_opts property to catalina.sh (for us on windows 2003 catalina.but). When running tomcat as a windows service this script file will not get accessed.
I thought the recommended way of setting java system properties for tomcat running as a windows service is to use tomcat5w.exe - but that is not working for me.

thomas

0
Comment actions Permalink

We run TeamCity and the integrated tomcat server as a
Windows Service on a Windows 2003 Server. You
suggested to add the java_opts property to
catalina.sh (for us on windows 2003 catalina.but).


You are right about how to setup java options as a Windows service. I happened to have Tomcat 5.5 loaded on my Windows XP desktop. Tomcat sees the new option but I can not say whether TeamCity recognizes it since my TC server and agent are on a Linux box. This is what I did:
- Launch: tomcat5w.exe
- Click on the Java tab
- Add "-Dmodification.check.interval=3600" to the Java Options section
- Click on the Logging tab
- Change Level to Debug
- Restart the Apache Tomcat Windows service
- I then found this in C:\Program Files\Apache Software Foundation\Tomcat 5.5\logs\jakarta_service_20070327.log:
Starting service...
Jvm Option[0] -Dcatalina.home=C:\Program Files\Apache Software Foundation\Tomcat 5.5
Jvm Option[1] -Dcatalina.base=C:\Program Files\Apache Software Foundation\Tomcat 5.5
Jvm Option[2] -Djava.endorsed.dirs=C:\Program Files\Apache Software Foundation\Tomcat 5.5\common\endorsed
Jvm Option[3] -Djava.io.tmpdir=C:\Program Files\Apache Software Foundation\Tomcat 5.5\temp
Jvm Option[4] -Djava.util.logging.manager=org.apache.juli.ClassLoaderLogManager
Jvm Option[5] -Djava.util.logging.config.file=C:\Program Files\Apache Software Foundation\Tomcat 5.5\conf\logging.properties
Jvm Option[6] -Dmodification.check.interval=3600
Jvm Option[7] -Djava.class.path=C:\Program Files\Apache Software Foundation\Tomcat 5.5\bin\bootstrap.jar
Jvm Option[8] vfprintf
argv[0] = start
Java started org/apache/catalina/startup/Bootstrap
Service started in 1171 ms.

Is that what you're seeing in the Tomcat log too but it doesn't affect TeamCity?

-Dave

0
Comment actions Permalink

Dave, you put me on the right track!

I had a tomcat 5.0 installation beside teamcity tomcat. When i started tomcat5w.exe from the teamcity install dir i always configured the default tomcat 5.0 installation. Teamcitys tomcat installation was not effected.
Then i uninstalled my tomcat 5.0 and could not start tomcat5w.exe from the teamcity install dir anymore. What me helped was this jira entry:
http://www.jetbrains.net/jira/browse/TW-2140

Dave, i thank you for your support.

thomas

0
Comment actions Permalink

Dave, you put me on the right track!


Glad it worked.

-Dave

0

Please sign in to leave a comment.