Checking for changes, getting project sources stages are too slow (TC 2.0)

Hello,
I'm not sure what TC does in these two stages (when it prints Checking for changes, getting project sources) but I would appreciate if TC could delay in them less time.

I'm running just a simple ant build that does nothing but compiles sources. When running in ant it takes less than 2 minutes to build the whole project.

When running in TC, it takes at least 15 minutes to compile the project (on the same machine). Most of the time, TC spends in 'checking for changes' and 'getting project sources' stages. The ant build obviously takes 2 minutes only.

In production it is not that harmful but in the time when I'm trying to setup a new build, waiting 15 minutes for TC just to learn that I have something wrong in the build setup, is quite annoying.

Can be this somehow manageble? (e.g. switched off) It would speed up setting up a new build significantly.

4 comments
Comment actions Permalink

Hello,

Which VCS do you use for your build? If you use SVN, try disabling "Externals" checkbox in corresponding VCS settings.

Kind regards,
KIR

0
Comment actions Permalink

By the way, what does "Enable externals support" mean?

Vitaly Berov

Kirill Maximov (JetBrains) wrote:

Hello,

Which VCS do you use for your build? If you use SVN, try disabling "Externals" checkbox in corresponding VCS settings.

Kind regards,
KIR

0
Comment actions Permalink

Unfortunatelly, we use CVS. Could TC support a switch that would turn off getting sources automatically? It would speed up the build setup process significantly.

0
Comment actions Permalink

You have to have the option enabled if the project contains externals
(something like link to the same or other svn repository).

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Vitaly Berov" <vitaly.berov@nivalonline.com> wrote in message
news:4610CA47.90904@nivalonline.com...

By the way, what does "Enable externals support" mean?

>

Vitaly Berov

>

Kirill Maximov (JetBrains) wrote:

>> Hello,
>>
>> Which VCS do you use for your build? If you use SVN, try disabling
>> "Externals" checkbox in corresponding VCS settings.
>>
>> Kind regards,
>> KIR


0

Please sign in to leave a comment.