TC plugin in IntelliJ

Hi,

I'm having trouble to login from the freshly installed IntelliJ plugin. The
first login try results in a messagebox saying:
"Cannot login to TeamServer: java.lang.NullPointerException"

Then subsequent retries give me this message:
"Cannot login to TeamServer: Call http://]]>:8111/RPC2
RemoteAuthenticationServer.getPublicKey: java.lang.NoClassDefFoundError:
Could not initialize class org.apache.commons.httpclient.HttpClient"
The TC icon located at the bottom right is an hourglass with this tooltip:
"Login in progress"

(I had the same problem with the older beta version of TC 2)

System:
- IntelliJ 6.0.5 build 6180 (under JDK 1.6.0), WinXP
- TeamCity Version 2.0 (build 4096), Linux, version 2.6.11-1.1369_FC4smp

Any tip on how to solve this problem?

Thanks
Melv


5 comments
Comment actions Permalink

Hello,

How did you update the plugin?
Could you try to remove plugin and install it again?
Thanks!

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Melv Ng" <pkng8791@hotmail.com> wrote in message
news:evfs1n$tn6$1@is.intellij.net...

Hi,

>

I'm having trouble to login from the freshly installed IntelliJ plugin.
The first login try results in a messagebox saying:
"Cannot login to TeamServer: java.lang.NullPointerException"

>

Then subsequent retries give me this message:
"Cannot login to TeamServer: Call http://<host>:8111/RPC2
RemoteAuthenticationServer.getPublicKey: java.lang.NoClassDefFoundError:
Could not initialize class org.apache.commons.httpclient.HttpClient"
The TC icon located at the bottom right is an hourglass with this tooltip:
"Login in progress"

>

(I had the same problem with the older beta version of TC 2)

>

System:
- IntelliJ 6.0.5 build 6180 (under JDK 1.6.0), WinXP
- TeamCity Version 2.0 (build 4096), Linux, version 2.6.11-1.1369_FC4smp

>

Any tip on how to solve this problem?

>

Thanks
Melv



0
Comment actions Permalink

I tried to reinstall by:
- close IntelliJ
- delete buildServerPlugin from "C:\Documents and
Settings\\.IntelliJIdea60\config\plugins" - unzip buildServerPlugin from the downloaded zip into that same dir, downloaded from "My Settings & Tools" page - restart IntelliJ - login from the menu TeamCity/Login, and I still got the same problem I get the same errors even if I enter a bogus password. If my installation procedure is correct, is there any log that might give me more hints on the problem? Thanks Melv "Olesya Smirnova" ]]> wrote in message
news:evg0ha$da2$1@is.intellij.net...

Hello,

>

How did you update the plugin?
Could you try to remove plugin and install it again?
Thanks!

>

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"Melv Ng" <pkng8791@hotmail.com> wrote in message
news:evfs1n$tn6$1@is.intellij.net...

>> Hi,
>>
>> I'm having trouble to login from the freshly installed IntelliJ plugin.
>> The first login try results in a messagebox saying:
>> "Cannot login to TeamServer: java.lang.NullPointerException"
>>
>> Then subsequent retries give me this message:
>> "Cannot login to TeamServer: Call http://:8111/RPC2 >> RemoteAuthenticationServer.getPublicKey: java.lang.NoClassDefFoundError: >> Could not initialize class org.apache.commons.httpclient.HttpClient" >> The TC icon located at the bottom right is an hourglass with this >> tooltip: >> "Login in progress" >> >> (I had the same problem with the older beta version of TC 2) >> >> System: >> - IntelliJ 6.0.5 build 6180 (under JDK 1.6.0), WinXP >> - TeamCity Version 2.0 (build 4096), Linux, version 2.6.11-1.1369_FC4smp >> >> Any tip on how to solve this problem? >> >> Thanks >> Melv >> >]]>



0
Comment actions Permalink

Attach IDEA logs please. Maybe they contain something useful.

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"


"Melv Ng" <pkng8791@hotmail.com> wrote in message
news:evi2r6$jt2$1@is.intellij.net...
>I tried to reinstall by:

- close IntelliJ
- delete buildServerPlugin from "C:\Documents and
Settings\<user>\.IntelliJIdea60\config\plugins"
- unzip buildServerPlugin from the downloaded zip into that same dir,
downloaded from "My Settings & Tools" page
- restart IntelliJ
- login from the menu TeamCity/Login, and I still got the same problem

>

I get the same errors even if I enter a bogus password.

>

If my installation procedure is correct, is there any log that might give
me more hints on the problem?

>

Thanks
Melv

>

"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:evg0ha$da2$1@is.intellij.net...

>> Hello,
>>
>> How did you update the plugin?
>> Could you try to remove plugin and install it again?
>> Thanks!
>>
>> --
>> Olesya Smirnova
>> JetBrains, Inc
>> http://www.jetbrains.com
>> "Develop with pleasure!"
>>
>>
>> "Melv Ng" wrote in message >> news:evfs1n$tn6$1@is.intellij.net... >>> Hi, >>> >>> I'm having trouble to login from the freshly installed IntelliJ plugin. >>> The first login try results in a messagebox saying: >>> "Cannot login to TeamServer: java.lang.NullPointerException" >>> >>> Then subsequent retries give me this message: >>> "Cannot login to TeamServer: Call http://:8111/RPC2 >>> RemoteAuthenticationServer.getPublicKey: java.lang.NoClassDefFoundError: >>> Could not initialize class org.apache.commons.httpclient.HttpClient" >>> The TC icon located at the bottom right is an hourglass with this >>> tooltip: >>> "Login in progress" >>> >>> (I had the same problem with the older beta version of TC 2) >>> >>> System: >>> - IntelliJ 6.0.5 build 6180 (under JDK 1.6.0), WinXP >>> - TeamCity Version 2.0 (build 4096), Linux, version 2.6.11-1.1369_FC4smp >>> >>> Any tip on how to solve this problem? >>> >>> Thanks >>> Melv >>> >> >> >]]>



0
Comment actions Permalink

Hi Olesya,

I sent you a mail with the log for some days ago. Any luck with tracing the
problem?

One member of our team installed IntelliJ 7.0 and logged in without problem.
It seems like the plugin breaks in 6.0 some some reason.

Melv

"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:evif62$kig$1@is.intellij.net...

Attach IDEA logs please. Maybe they contain something useful.

>

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"Melv Ng" <pkng8791@hotmail.com> wrote in message
news:evi2r6$jt2$1@is.intellij.net...

>>I tried to reinstall by:
>> - close IntelliJ
>> - delete buildServerPlugin from "C:\Documents and
>> Settings\\.IntelliJIdea60\config\plugins" >> - unzip buildServerPlugin from the downloaded zip into that same dir, >> downloaded from "My Settings & Tools" page >> - restart IntelliJ >> - login from the menu TeamCity/Login, and I still got the same problem >> >> I get the same errors even if I enter a bogus password. >> >> If my installation procedure is correct, is there any log that might give >> me more hints on the problem? >> >> Thanks >> Melv >> >> "Olesya Smirnova" wrote in message >> news:evg0ha$da2$1@is.intellij.net... >>> Hello, >>> >>> How did you update the plugin? >>> Could you try to remove plugin and install it again? >>> Thanks! >>> >>> -- >>> Olesya Smirnova >>> JetBrains, Inc >>> http://www.jetbrains.com >>> "Develop with pleasure!" >>> >>> >>> "Melv Ng" wrote in message >>> news:evfs1n$tn6$1@is.intellij.net... >>>> Hi, >>>> >>>> I'm having trouble to login from the freshly installed IntelliJ plugin. >>>> The first login try results in a messagebox saying: >>>> "Cannot login to TeamServer: java.lang.NullPointerException" >>>> >>>> Then subsequent retries give me this message: >>>> "Cannot login to TeamServer: Call http://:8111/RPC2 >>>> RemoteAuthenticationServer.getPublicKey: >>>> java.lang.NoClassDefFoundError: Could not initialize class >>>> org.apache.commons.httpclient.HttpClient" >>>> The TC icon located at the bottom right is an hourglass with this >>>> tooltip: >>>> "Login in progress" >>>> >>>> (I had the same problem with the older beta version of TC 2) >>>> >>>> System: >>>> - IntelliJ 6.0.5 build 6180 (under JDK 1.6.0), WinXP >>>> - TeamCity Version 2.0 (build 4096), Linux, version >>>> 2.6.11-1.1369_FC4smp >>>> >>>> Any tip on how to solve this problem? >>>> >>>> Thanks >>>> Melv >>>> >>> >>> >> >> >]]>



0
Comment actions Permalink

Hi again :)

I just installed Idea 7.0M1 and used the plugin without any problems. It
would be great if I can use it in 6.0 also :) I will gladly help if you need
any testing or logs.

Thanks,
Melv


"Olesya Smirnova" <Olesya.Smirnova@jetbrains.com> wrote in message
news:evif62$kig$1@is.intellij.net...

Attach IDEA logs please. Maybe they contain something useful.

>

--
Olesya Smirnova
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

>
>

"Melv Ng" <pkng8791@hotmail.com> wrote in message
news:evi2r6$jt2$1@is.intellij.net...

>>I tried to reinstall by:
>> - close IntelliJ
>> - delete buildServerPlugin from "C:\Documents and
>> Settings\\.IntelliJIdea60\config\plugins" >> - unzip buildServerPlugin from the downloaded zip into that same dir, >> downloaded from "My Settings & Tools" page >> - restart IntelliJ >> - login from the menu TeamCity/Login, and I still got the same problem >> >> I get the same errors even if I enter a bogus password. >> >> If my installation procedure is correct, is there any log that might give >> me more hints on the problem? >> >> Thanks >> Melv >> >> "Olesya Smirnova" wrote in message >> news:evg0ha$da2$1@is.intellij.net... >>> Hello, >>> >>> How did you update the plugin? >>> Could you try to remove plugin and install it again? >>> Thanks! >>> >>> -- >>> Olesya Smirnova >>> JetBrains, Inc >>> http://www.jetbrains.com >>> "Develop with pleasure!" >>> >>> >>> "Melv Ng" wrote in message >>> news:evfs1n$tn6$1@is.intellij.net... >>>> Hi, >>>> >>>> I'm having trouble to login from the freshly installed IntelliJ plugin. >>>> The first login try results in a messagebox saying: >>>> "Cannot login to TeamServer: java.lang.NullPointerException" >>>> >>>> Then subsequent retries give me this message: >>>> "Cannot login to TeamServer: Call http://:8111/RPC2 >>>> RemoteAuthenticationServer.getPublicKey: >>>> java.lang.NoClassDefFoundError: Could not initialize class >>>> org.apache.commons.httpclient.HttpClient" >>>> The TC icon located at the bottom right is an hourglass with this >>>> tooltip: >>>> "Login in progress" >>>> >>>> (I had the same problem with the older beta version of TC 2) >>>> >>>> System: >>>> - IntelliJ 6.0.5 build 6180 (under JDK 1.6.0), WinXP >>>> - TeamCity Version 2.0 (build 4096), Linux, version >>>> 2.6.11-1.1369_FC4smp >>>> >>>> Any tip on how to solve this problem? >>>> >>>> Thanks >>>> Melv >>>> >>> >>> >> >> >]]>



0

Please sign in to leave a comment.