Reconnecting the default agent after sleeping a laptop...

I've been giving TeamCity 2.1.1 a trial run on my laptop (MacBook) and
just using the default build agent.

One thing I've noticed is that whenever I wake up the laptop after it
being in a sleep state, the build agent gets disabled with a message of
"could not ping".

Selecting "enable" to reenable the agent enables it in the TC gui but no
builds start unless I stop/start the server again.

Is there anyway to get the agent to automagically reconnect/restart?
(the process seems to still be running).

Mark

2 comments

Mark,

Could you please check if your laptop changes IP address before and after going to sleep?

"Ping failed" is the reason of the agent being disconnected (no connection between agent and server). Could you please look for the reason of agent disabling (on agent's page or in mouseover tooltip over the callout icon near "Disabled" text)? Agent is automatically disabled when its IP changes.

I am afraid, in the current version agent can't recover from the computer IP change without agent restarting. This is addressed by http://www.jetbrains.net/jira/browse/TW-2960 and hopefully will be fixed in the next release.

--
Best regards,

Yegor Yarko
Quality Assurance Engineer
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Yegor Yarko (JetBrains) wrote:

Could you please check if your laptop changes IP address before and
after going to sleep?


That makes sense - I mostly noticed it when moving between home and work
which uses two different wifi points which would give different IPs.

It's not a major problem thou.

0

Please sign in to leave a comment.