TeamCity Build Agent Service doesn't start well

When I start my laptop, Windows shows an error relates with java.exe (see the screenshot - http://www.geocities.com/t800t8/error.png) every 30 seconds (if I close the previous error message). I set TeamCity Build Agent Service starts manually and don't have this problem. But I don't see any error in teamcity-agent.log.

T.

PS: Please enable to upload files to this forum.

10 comments

Hello Eugene,

Does that happens what Windows starts? Do you have some antivirus programs
enabled?

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

When I start my laptop, Windows shows an error relates with java.exe
(see the screenshot - http://www.geocities.com/t800t8/error.png) every
30 seconds (if I close the previous error message). I set TeamCity
Build Agent Service starts manually and don't have this problem. But I
don't see any error in teamcity-agent.log.

T.

PS: Please enable to upload files to this forum.



0

Hello Eugene,

I'm not Eugene, you're Eugene :)

Seems the problem is caused by Kaspersky Anti-Virus 7.0.0.125. I added C:\TeamCity and C:\Documents and Settings\[USER]\.BuildServer to trusted zone of KAV but it doesn't help.

And I'm sure that it's problem of TeamCity Build Agent Service. 'Cause I set the service to start manually, then restart Windows and start the service, the same problem happens.

Is there any workarounds?

T.

Message was edited by:
t800t8

0

Hello,

I'm sorry for my news-reader to call you Eugene.

Could you please to post a Jira issue for the problem. It seems the problem
connected with creating new java process from the service process. There
are 3 processes: JavaServiceWrapper process -> luncher process -> agent process.

Is that possible to stop KAV, start agent service? Does that work?

Could you please attach all agent logs

Thanks!


--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Eugene,

I'm not Eugene, you're Eugene :)

Seems the problem is caused by Kaspersky Anti-Virus 7.0.0.125. I added
C:\TeamCity and C:\Documents and Settings\[USER]\.BuildServer to
trusted zone of KAV but it doesn't help.

Is there any workarounds?

T.



0

Hello Eugene,

If I stop KAV and start agent service, everything is fine.

And are all agent logs stored in C:\TeamCity\buildAgent\logs? Or anywhere else? I'm a newbie with TeamCity.

T.

0

Hello,

Yes, all logs of agent are stored to ]]>/logs.

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Eugene,

If I stop KAV and start agent service, everything is fine.

And are all agent logs stored in C:\TeamCity\buildAgent\logs? Or
anywhere else? I'm a newbie with TeamCity.

T.



0

Hello,

Could you please try to find file hs_err_pid3088.log on your machine. This
file is a crash log created by java.exe.
Please check : /bin, /launcher/bin or ]]>.

Thanks!
--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Done, http://www.jetbrains.net/jira/browse/TW-4085



0

Done, attached it to the bug report.

0

Hello Eugene,

Thanks!

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Done, attached it to the bug report.



0

Hello,

Please sorry for calling you Eugene.

--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Hello Eugene,

Thanks!

>> Done, attached it to the bug report.
>>


0

Please sign in to leave a comment.