Teamcity SVN checkout: dateattribute problem

Hello to the forum.

We are currently using Teamcity Professional Version 3.0.1. in combination with Subversion and an ARM compiler.
VCS checkout mode is "automatically on server"

Problem:
Our first build takes 10 times the time (around 55min), a rebuild would take, because our arm compiler needs to build the project from scratch (not using precompiled libs and object files), although it wouldn't be necessary!!!

Irrespective from arm compiler setting (that also need some tweaks!! ;)), the problem mainly is caused by teamcity, which fetches data from subversion and touches all files with actual date attributes.

Is there a way to prevent teamcity from that?

6 comments

Nobody out there, who has a clue? :(

0

Hello,

sorry for delay. Server side checkout sets current date for each file. There is no option to change the behavior. Try to use agent side checkout.

0

Hi!

If you feel that this is an important feature to support by TeamCity, please create an issue in our tracker: http://jetbrains.net/jira/browse/TW

--
Best regards,

Yegor Yarko
Project Manager
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

0

Looks like this is mainly a Subversion problem: it's possible to set Subversion checkouts to "commit"-date" or "actual"-date, but unfortunately NOT to "last-modified"-date!!

In our case, this "commit-date" will help me out. :)

You just have to set:

to
use-commit-times=yes

See discussion to this prob here:

http://svn.haxx.se/tsvnusers/archive-2007-03/0002.shtml#start

"....It's fairly well-known and documented (and often discussed to death on
the Subversion mailing list) that Subversion doesn't maintain
last-modified dates as part of the versioned data. At one time there
was a series of patches to do this and some other metadata, but I
don't think it's maintained anymore.


You can configure your client(s) to set the date/time of items in your
WC to the time the files were committed by setting use-commit-times =
yes in the section of your config file.
..."

0

Please sign in to leave a comment.