Upgrade from TeamCity 2.1.1 to 3.0.1 causes going to Professional mode

Hi,

I was told by Kirill that those with TeamCity 2.1.1 licenses would get a free upgrade tp TeamCity 3.0.1. However, I just upgraded to 3.0.1 and have the following msgs on the screen after I log in:

This TeamCity installation has 39 build configurations. Only 20 configurations are allowed
in TeamCity Professional. Builds won't run until you either remove extra build
configurations or enter an Enterprise license.

This TeamCity installation is using LDAP server authentication. TeamCity Professional
works only with TeamCity built-in authentication.
Builds won't run until you either change the authentication scheme. (NOTE: all user data
will be lost, but build configurations will remain) or enter an Enterprise license.

What can be done to fix this? Should I contact the sales dept?

Thanks,
-Dave

2 comments

Hello Dave,

DL> What can be done to fix this? Should I contact the sales dept?


Yep, contact them and they'll send you an enterprise license. See here for
more details:

http://www.jetbrains.com/teamcity/buy/index.html#upgradeuser
http://www.jetbrains.com/teamcity/buy/index.html#upgradeuser_enterprise

HTH,
Andrei


0

Yep, contact them and they'll send you an enterprise license.


Okay. Thanks. I have contacted them and received a new license key.

It would have been nice to know this before upgrading.
There is nothing in the "Upgrading TeamCity" documentation about the need
to acquire a new license key in order to run in Enterprise mode.

-Dave

0

Please sign in to leave a comment.