How to run test with VSTS?

My VS 2008 solution has one unit testing project which is run using VSTS. I do not use NUnit. I was able to configure TeamCity to use the 2008 sln, I was also able to configure it to run the unit tests in my DLL but is appears that it tries to use NUnit instead of VSTS. The result is that the majority of my tests are skipped since the NUnit and the VSTS syntaxes are a little bit different.

Looking at the build log, I see the following:
: [Target "NUnit_TeamCity_generated_93de5605af82429087818bfee99ed3a3" in project "Meeting Central Project.sln.teamcity.patch.proj"] Using "CreateItem" task from assembly "Microsoft.Build.Tasks, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a".[05:35:44]: [Target "NUnit_TeamCity_generated_93de5605af82429087818bfee99ed3a3" in project "Meeting Central Project.sln.teamcity.patch.proj"] Using "NUnitTeamCity" task from assembly "C:\BuildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.MSBuildLoggers.dll".[05:35:44]: [Target "NUnit_TeamCity_generated_93de5605af82429087818bfee99ed3a3" in project "Meeting Central Project.sln.teamcity.patch.proj"] Command:[05:35:44]: [Target "NUnit_TeamCity_generated_93de5605af82429087818bfee99ed3a3" in project "Meeting Central Project.sln.teamcity.patch.proj"] C:\BuildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher2.0.exe "WebExApiUnitTests\bin\Release\WebExApiTest.dll" : [Target "NUnit_TeamCity_generated_93de5605af82429087818bfee99ed3a3" in project "Meeting Central Project.sln.teamcity.patch.proj"] The "NUnitTeamCity" task is using "JetBrains.BuildServer.NUnitLauncher2.0.exe" from "C:\BuildAgent\plugins\dotnetPlugin\bin\JetBrains.BuildServer.NUnitLauncher2.0.exe".[05:35:47]: [Target "NUnit_TeamCity_generated_93de5605af82429087818bfee99ed3a3" in project "Meeting Central Project.sln.teamcity.patch.proj"] WebExApiTest.dll (1s)

Can anybody help me figure out why TeamCity wants to use NUnit instead of VSTS?

3 comments
Comment actions Permalink

Here's additional info: when a build completes, it says "Tests passed: 6, Ignored: 214" and it lists all the ignored tests like this one for example:
TelephonyOptionsTest.TelephonyOptionsPropertiesTest (ApiTest.EventService) - Invalid TestFixtureSetUp method signature

0
Comment actions Permalink

Hello,
Thank you for feedback. Please file a jira request at
http://www.jetbrains.net/jira/browse/TW

Could you please attach some code examle of that non-working test.

BTW. What VS do you use? We have an issue of VS2008 Tests at
http://www.jetbrains.net/jira/browse/TW-4485. Are those problems the same?

Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Here's additional info: when a build completes, it says "Tests passed:
6, Ignored: 214" and it lists all the ignored tests like this one for
example:

TelephonyOptionsTest.TelephonyOptionsPropertiesTest
(ApiTest.EventService) - Invalid TestFixtureSetUp method signature



0
Comment actions Permalink

Yes I am using VS2008. The problem I'm experiencing appears to be very similar to http://www.jetbrains.net/jira/browse/TW-4485

0

Please sign in to leave a comment.