Problem running Nant

Hello,

I'm trying to set up a project using nant 0.86 and TeamCity 3.0.1. However, everytime I try and run the build I get the following errors:

Method not found: 'Void NAnt.Core.TaskBuilder..ctor(System.Reflection.Assembly, System.String)'.
Method not found: 'Void NAnt.Core.TaskBuilder..ctor(System.Reflection.Assembly, System.String)'.
StackTrace:
at JetBrains.BuildServer.NAntLoggers.NAntListenerImpl.PatchTask(String name, Type t)
at JetBrains.BuildServer.NAntLoggers.NAntListenerImpl.PatchTasks() in c:\Agent\work\c16bf1686436dd12\DotNet-listeners\NAntLoggers\src\NAntListenerImpl.cs:line 101
at JetBrains.BuildServer.NAntLoggers.NAntListenerImpl.BuildStarted(Object sender, BuildEventArgs e) in c:\Agent\work\c16bf1686436dd12\DotNet-listeners\NAntLoggers\src\NAntListenerImpl.cs:line 139
at JetBrains.BuildServer.NAntLoggers.NAntListener.BuildStarted(Object sender, BuildEventArgs e) in c:\Agent\work\c16bf1686436dd12\DotNet-listeners\NAntLoggers\src\NAntListener.cs:line 32
at NAnt.Core.BuildEventHandler.Invoke(Object sender, BuildEventArgs e)
at NAnt.Core.Project.OnBuildStarted(Object sender, BuildEventArgs e)
at NAnt.Core.Project.Run()

Any ideas?

Thanks

2 comments

I think I got the same error when I tried to use 0.86-beta1 (which AFAIK is the only available 0.86 version). Switching to 0.85 solved the problem, the docs also implicitly say this:
http://www.jetbrains.net/confluence/display/TCD3/.NetTestingFrameworks+Support

"TeamCity 3.1 also supports for the NAnt 0.86 runner and the NUnit 2.4 testing framework."

While it doesn't explicitly say this, it does seem like this is new as of 3.1.

0

That was the problem.

Many thanks

0

Please sign in to leave a comment.