TeamCity confused on checkout directories

We have a directory structure in CVS like so:


/product
+-/src
+-/install


Currently, somehow TeamCity thinks changes to the src directory are
occurring in the install directory!

So, if I commit /product/src/Foo.cs, it shows up in the Pending/Changes
Web UI as: /product/install/Foo.cs!! And there's definitely no Foo.cs in
our install folder.

I've double-checked the VCS pull configuration - checkout rules - we're
not redirecting any of the pulled folders to other local folders.

What do I need to reset to get TeamCity back on track? (Trying clean
pulls now, but it doesn't seem to be working).

3.01 (build 6010)

8 comments

I found the sourceCaches folder, and am trying to delete the .cache
files, plus change all my build configs to pull on the agent instead. I
recently changed many of them from agent pull to server pull, and didn't
seem to have these problems before.

0

This is still broken. TeamCity is still detecting file changes in the
wrong folder. Any ideas on how to fix this?

0

Hello Chris,

this problem should be fixed in 3.1 (see http://jetbrains.net/tracker/_htmlTemplate/Issue?issue=25-4197).

Please let me know if it is fixed for you in 3.1

0

Chris, what's about the checked out sources? Are they checked out into wrong directory also?

0

Olesya Smirnova wrote:

Chris, what's about the checked out sources? Are they checked out into wrong directory also?


No, they appear fine.

0

Is it 100% reproducible? Could you restart the server with -Dcvs.do.output=true option, change the file, wait until the file is shown in pending changes and send to me cvs.output file from the server bin directory (with a name of the changed file)? Thanks!

0

BTW, what TC server version do you use right now?

0

Olesya Smirnova wrote:

BTW, what TC server version do you use right now?


3.0.1 6010

The JIRA issue you linked me to does appear to be the same issue.

I'm too busy right now to stop down and get a log, I might be able to
get another dev here to do that.

0

Please sign in to leave a comment.