DEP Status change on NUnit runner?

Since upgrading to 3.1 from 3.0.1 - we had a number of tests in our
suite start failing - most of them which interact with an ActiveX
control that apparently can succumb to DEP problems being compiled with
ATL in Visual Studio 2003. We're still investigating this theory, that
maybe DEP is related to these failures, so thought I'd ask -- does the
3.1 NUnit runner now have DEP status enabled?

2 comments

Chris Morris wrote:

Since upgrading to 3.1 from 3.0.1 - we had a number of tests in our
suite start failing - most of them which interact with an ActiveX
control that apparently can succumb to DEP problems being compiled with
ATL in Visual Studio 2003. We're still investigating this theory, that
maybe DEP is related to these failures, so thought I'd ask -- does the
3.1 NUnit runner now have DEP status enabled?



FWIW, we were able to verify DEP doesn't seem to be involved here at
all. 3.1 runner doesn't show DEP enabled under Process Explorer.

0

Hello,
Actually we build our assemblies as pure MSIL, but for some cases x64 or
x64 flags are set.
As far as I know starting from some versions .NET Frameworks have started
to support DEP.
Is should be possible to disable DEP for user processes on XP

Thanks!
--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Chris Morris wrote:

>> Since upgrading to 3.1 from 3.0.1 - we had a number of tests in our
>> suite start failing - most of them which interact with an ActiveX
>> control that apparently can succumb to DEP problems being compiled
>> with ATL in Visual Studio 2003. We're still investigating this
>> theory, that maybe DEP is related to these failures, so thought I'd
>> ask -- does the 3.1 NUnit runner now have DEP status enabled?
>>

FWIW, we were able to verify DEP doesn't seem to be involved here at
all. 3.1 runner doesn't show DEP enabled under Process Explorer.



0

Please sign in to leave a comment.