VS Plug In grayed out

Team City: Version 3.1 (build 6760)
Visual Studio 2005

I have a 'clean' machine and verified that all Team City addons/build agents, etc. are removed.

I shutdown all of my VS applications and rebooted my laptop.

I then chose to download the VS plug in and ran the installation without an issue. However when I attempt to use the plug-in, I don't have the TC bar, and the Team City Dropdown is not enabled.

Is there another setting I need?

Thanks

5 comments

Hello,

What version of VS2005 do you have?
Was VS opened while the installation?

TeamCity plugin only enabled when some solution is opened.

Do you have ReSharper/dotTrace installed? If yes, what version?

Could you please check weather there is TeamCity plugin in the about box
of Visual Studio.

Thanks!
--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Team City: Version 3.1 (build 6760) Visual Studio 2005

I have a 'clean' machine and verified that all Team City addons/build
agents, etc. are removed.

I shutdown all of my VS applications and rebooted my laptop.

I then chose to download the VS plug in and ran the installation
without an issue. However when I attempt to use the plug-in, I don't
have the TC bar, and the Team City Dropdown is not enabled.

Is there another setting I need?

Thanks



0

Microsoft Visual Studio 2005
Version 8.0.50727.762 (SP.050727-7600)
Microsoft .NET Framework
Version 2.0.50727 SP1

Installed Edition: Professional

Microsoft Visual Basic 2005 77626-009-0000007-41862
Microsoft Visual Basic 2005

Microsoft Visual C# 2005 77626-009-0000007-41862
Microsoft Visual C# 2005

Microsoft Visual Web Developer 2005 77626-009-0000007-41862
Microsoft Visual Web Developer 2005

Microsoft Web Application Projects 2005 77626-009-0000007-41862
Microsoft Web Application Projects 2005
Version 8.0.50727.762

Visual Studio 2005 Team Explorer 77626-009-0000007-41862
Microsoft Visual Studio 2005 Team Explorer
Version 8.0.50727.762

Enterprise Library Configuration Editor 3.0
Microsoft patterns & practices Enterprise Library Configuration Editor

Microsoft Recipe Framework Package 8.0
This package provides services to the guidance packages.

Microsoft Visual Studio 2005 Professional Edition - ENU Service Pack 1 (KB926601)
This service pack is for Microsoft Visual Studio 2005 Professional Edition - ENU.

ReSharper 4 Full Edition build 4.0.755.30 on 2008-03-17T21:02:48
ReSharper add-in for Microsoft Visual Studio. For more information about ReSharper, see the ReSharper website at http://www.jetbrains.com/resharper. Copyright © 2003–2008 JetBrains, Inc

TeamCity 3.0 (build #4065)
TeamCity integration package for Microsoft Visual Studio 2005.
Allows to open stacktraces and files in Microsoft Visual Studio 2005 by clicking the links on TeamCitys web pages.
For more information, please visit http://www.jetbrains.com/teamcity.

This version information concerns me as it does not match the version of Team City we are using. I downloaded from the link on the server and this time saved to my desktop.

When I look at the properities of the file I see the following:
Subject: JetBrains TeamCity Add-in 3.1 for Microsoft Visual Studio
Revision number: {607AB6BB-649E-4EAC-9578-FCDEBB69015A}

Is it possible that the server has the wrong version of the installer? Is it possible to just get the installer for the build or do I need to download the newer version, backup the configuration files (as per the documentation files), uninstall and reinstall the new version?

Thank you

0

Hello,
The older version of plugin should at least show you login dialog. After
logging in, it should suggest you updating. BTW what server version do you
use?
Could you please try do the following:
- stop all VS provesses
- run devenv.exe /setup
- wait using process explorer or task manager till it finishes.

Does that helped?

Do you see some tool windows of TeamCity plugin? Do you have TeamCity toolbar?

BTW, have you customized toolbars in VS?

Could you please attach some logs from ]]>/Local Settings/Temp/JetLogs/
For doing it, close all VS, remove all files there. Start devenv.exe /setup
copy created log and rename it.
Start VS. Try opening solution. Close VS. Take newly created log.

Thanks!
--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Microsoft Visual Studio 2005
Version 8.0.50727.762 (SP.050727-7600)
Microsoft .NET Framework
Version 2.0.50727 SP1
Installed Edition: Professional

Microsoft Visual Basic 2005 77626-009-0000007-41862 Microsoft Visual
Basic 2005

Microsoft Visual C# 2005 77626-009-0000007-41862 Microsoft Visual C#
2005

Microsoft Visual Web Developer 2005 77626-009-0000007-41862
Microsoft Visual Web Developer 2005

Microsoft Web Application Projects 2005 77626-009-0000007-41862
Microsoft Web Application Projects 2005
Version 8.0.50727.762
Visual Studio 2005 Team Explorer 77626-009-0000007-41862
Microsoft Visual Studio 2005 Team Explorer
Version 8.0.50727.762
Enterprise Library Configuration Editor 3.0
Microsoft patterns & practices Enterprise Library Configuration Editor
Microsoft Recipe Framework Package 8.0
This package provides services to the guidance packages.
Microsoft Visual Studio 2005 Professional Edition - ENU Service Pack 1
(KB926601) This service pack is for Microsoft Visual Studio 2005
Professional Edition - ENU.

ReSharper 4 Full Edition build 4.0.755.30 on 2008-03-17T21:02:48
ReSharper add-in for Microsoft Visual Studio. For more information
about ReSharper, see the ReSharper website at
http://www.jetbrains.com/resharper. Copyright © 2003-2008 JetBrains,
Inc

TeamCity 3.0 (build #4065)
TeamCity integration package for Microsoft Visual Studio 2005.
*Allows to open stacktraces and files in Microsoft Visual Studio 2005
by clicking the links on TeamCitys web pages.*
*For more information, please visit
http://www.jetbrains.com/teamcity.*
This version information concerns me as it does not match the version
of Team City we are using. I downloaded from the link on the server
and this time saved to my desktop.

When I look at the properities of the file I see the following:
Subject: JetBrains TeamCity Add-in 3.1 for Microsoft Visual Studio
Revision number: {607AB6BB-649E-4EAC-9578-FCDEBB69015A}

Is it possible that the server has the wrong version of the installer?
Is it possible to just get the installer for the build or do I need
to download the newer version, backup the configuration files (as per
the documentation files), uninstall and reinstall the new version?

Thank you



0

Yes that helped, in that it is no longer grayed out.
It did not provide an option to 'download update" perhaps it decided that no update was required.

However there were a series of 1:45:21 PM.432: Thread:13: Unexpected element type Enum errors in the log. I have the log saved and can send it if necessary.

If you can confirm that it shouldn't have given me the option to download and update, I will mark this as answered.

Thanks a lot! I love how you are quick to respond and have non-cryptic answers.

Edited by: Stephen Costanzo on Apr 9, 2008 1:54 PM

0

Hello,
Actually Enum problem happen because of protocol change. It would be good
to have a look to the logs.

Thanks!
--
Eugene Petrenko
JetBrains, Inc
http://www.jetbrains.com
"Develop with pleasure!"

Yes that helped, in that it is no longer grayed out. It did not
provide an option to 'download update" perhaps it decided that no
update was required.

However there were a series of *1:45:21 PM.432: Thread:13: Unexpected
element type Enum* errors in the log. I have the log saved and can
send it if necessary.

If you can confirm that it shouldn't have given me the option to
download and update, I will mark this as answered.

Thanks a lot! I love how you are quick to respond and have non-cryptic
answers.

Edited by: Stephen Costanzo on Apr 9, 2008 1:54 PM



0

Please sign in to leave a comment.